allow target specific builddir list override
authorFelix Fietkau <nbd@openwrt.org>
Sat, 28 Jul 2007 03:01:10 +0000 (03:01 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 28 Jul 2007 03:01:10 +0000 (03:01 +0000)
SVN-Revision: 8204

include/subdir.mk

index 046a6adf6f370c32310d8b5d933a8eb23b833c42..79624238b5a027980f40f0a7a58b60852fa8dbd2 100644 (file)
@@ -39,7 +39,7 @@ define subdir
        )
   )
   $(foreach target,$(SUBTARGETS),
-    $(call warn_eval,$(1),t,T,$(1)/$(target): $($(1)/) $(foreach bd,$($(1)/builddirs),$(1)/$(bd)/$(target)))
+    $(call warn_eval,$(1),t,T,$(1)/$(target): $($(1)/) $(foreach bd,$(if $($(1)/builddirs-$(target)),$($(1)/builddirs-$(target)),$($(1)/builddirs)),$(1)/$(bd)/$(target)))
   )
 endef