quilt: add a NO_RECONFIGURE override for compiling a package without re-running Build...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 13 Feb 2012 15:31:28 +0000 (15:31 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 13 Feb 2012 15:31:28 +0000 (15:31 +0000)
SVN-Revision: 30500

include/quilt.mk

index a9af2268bc2273b8b12665e3248a4fd59edba55b..925b7a736bd83710331c4396b804d8593505e58f 100644 (file)
@@ -125,7 +125,8 @@ define Quilt/Refresh/Kernel
 endef
 
 define Quilt/Template
-  $($(2)STAMP_CONFIGURED): $($(2)STAMP_CHECKED) FORCE
+  $($(2)STAMP_CONFIGURED): $($(2)STAMP_CHECKED)
+  $(if $(NO_RECONFIGURE),$($(2)STAMP_BUILT),$($(2)STAMP_CONFIGURED)): FORCE
   $($(2)STAMP_CHECKED): $($(2)STAMP_PREPARED)
        if [ -s "$(1)/patches/series" ]; then \
                (cd "$(1)"; \