tools/cmake: update to 3.4.0
authorJohn Crispin <john@openwrt.org>
Sat, 21 Nov 2015 21:26:02 +0000 (21:26 +0000)
committerJohn Crispin <john@openwrt.org>
Sat, 21 Nov 2015 21:26:02 +0000 (21:26 +0000)
Update cmake to 3.4.0.
Refresh patches.

Signed-off-by: Hannu Nyman <hannu.nyman@iki.fi>
SVN-Revision: 47568

tools/cmake/Makefile
tools/cmake/patches/100-disable_qt_tests.patch
tools/cmake/patches/110-freebsd-compat.patch

index b71f1af626fe426f4b98e030b3035c1e8987bd7e..fab2be6fa15a22cd4fd16c1a04e720a045628223 100644 (file)
@@ -7,12 +7,12 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=cmake
-PKG_VERSION:=3.3.2
+PKG_VERSION:=3.4.0
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
-PKG_SOURCE_URL:=http://www.cmake.org/files/v3.3/ \
+PKG_SOURCE_URL:=http://www.cmake.org/files/v3.4/ \
                https://fossies.org/linux/misc/
-PKG_MD5SUM:=5febbd11bcaac854a27eebaf4a124be2
+PKG_MD5SUM:=cd3034e0a44256a0917e254167217fc8
 
 HOST_BUILD_PARALLEL:=1
 HOST_CONFIGURE_PARALLEL:=1
index deaa5ae48cf0e804fa570e5fd67fe73277d58ce4..417e27afab9101c88f98a31bf80485f4be16be89 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Tests/RunCMake/CMakeLists.txt
 +++ b/Tests/RunCMake/CMakeLists.txt
-@@ -160,15 +160,6 @@
+@@ -216,15 +216,6 @@
  add_RunCMake_test(no_install_prefix)
  add_RunCMake_test(configure_file)
  
@@ -18,7 +18,7 @@
    add_RunCMake_test(FindPkgConfig)
 --- a/Tests/CMakeLists.txt
 +++ b/Tests/CMakeLists.txt
-@@ -358,10 +358,6 @@
+@@ -390,10 +390,6 @@
  
    list(APPEND TEST_BUILD_DIRS ${CMake_TEST_INSTALL_PREFIX})
  
index 9133db5038f09b29b08de2f9018088b7b1d002e0..b54944829b590c958daa5302ed4c62966d23c340 100644 (file)
@@ -23,7 +23,7 @@ diff --git a/Source/kwsys/SystemInformation.cxx b/Source/kwsys/SystemInformation
 index 7c31f3a..2672730 100644
 --- a/Source/kwsys/SystemInformation.cxx
 +++ b/Source/kwsys/SystemInformation.cxx
-@@ -91,6 +91,15 @@ typedef int siginfo_t;
+@@ -90,6 +90,15 @@ typedef int siginfo_t;
  #  include <ifaddrs.h>
  #  define KWSYS_SYSTEMINFORMATION_IMPLEMENT_FQDN
  # endif