sdk: do not strip static libraries
authorJo-Philipp Wich <jo@mein.io>
Wed, 18 Jan 2017 02:15:31 +0000 (03:15 +0100)
committerJo-Philipp Wich <jo@mein.io>
Wed, 18 Jan 2017 02:18:53 +0000 (03:18 +0100)
Do not strip static libraries shipped with the SDK in order to preserve the
archive index. If we strip the index of the shipped libraries, host programs
will fail to link these libraries with errors like:

    libssl.a: error adding symbols: Archive has no index; run ranlib to add one

The error was found while investigating a Python host build failure within
the SDK environment.

Signed-off-by: Jo-Philipp Wich <jo@mein.io>
target/sdk/Makefile

index e9599c3c69ee0142567b2021a728e29b81d52b08..496f0253936f5b7ff398a23cfd07a6521ce64e6d 100644 (file)
@@ -92,7 +92,7 @@ $(BIN_DIR)/$(SDK_NAME).tar.xz: clean
                find \
                        $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/lib \
                        $(SDK_BUILD_DIR)/$(STAGING_SUBDIR_HOST)/usr/lib \
-                       -type f -name \*.so\* -or -name \*.a; \
+                       -type f -name \*.so\*; \
        ) | xargs strip 2>/dev/null >/dev/null
 
        mkdir -p $(SDK_BUILD_DIR)/target/linux