usign: add new package for generating/verifying verification (similar to signify)
authorFelix Fietkau <nbd@openwrt.org>
Mon, 6 Apr 2015 19:38:07 +0000 (19:38 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 6 Apr 2015 19:38:07 +0000 (19:38 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 45283

package/system/usign/Makefile [new file with mode: 0644]

diff --git a/package/system/usign/Makefile b/package/system/usign/Makefile
new file mode 100644 (file)
index 0000000..3f32438
--- /dev/null
@@ -0,0 +1,39 @@
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=usign
+PKG_VERSION:=2015-04-06
+PKG_RELEASE=$(PKG_SOURCE_VERSION)
+
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_URL:=git://git.openwrt.org/project/usign.git
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_VERSION:=395369a223b6c48e0d897d0c4c4d17236edbeea9
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
+CMAKE_INSTALL:=1
+PKG_CHECK_FORMAT_SECURITY:=1
+PKG_USE_MIPS16:=0
+
+PKG_LICENSE:=ISC
+PKG_LICENSE_FILES:=
+
+PKG_MAINTAINER:=Felix Fietkau <nbd@openwrt.org>
+
+include $(INCLUDE_DIR)/package.mk
+include $(INCLUDE_DIR)/host-build.mk
+include $(INCLUDE_DIR)/cmake.mk
+
+define Package/usign
+  SECTION:=base
+  CATEGORY:=Base system
+  TITLE:=OpenWrt signature verification utility
+endef
+
+define Package/usign/install
+       $(INSTALL_DIR) $(1)/usr/bin
+
+       $(INSTALL_BIN) $(PKG_INSTALL_DIR)/usr/bin/usign $(1)/usr/bin
+       ln -s usign $(1)/usr/bin/signify
+endef
+
+$(eval $(call BuildPackage,usign))
+$(eval $(call HostBuild))