ipq806x: fix R7500 kernel generation
authorJonas Gorski <jogo@openwrt.org>
Thu, 10 Sep 2015 10:09:26 +0000 (10:09 +0000)
committerJonas Gorski <jogo@openwrt.org>
Thu, 10 Sep 2015 10:09:26 +0000 (10:09 +0000)
Obviously the dummy rootfs must be after the kernel (uImage), not
included in it.

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 46837

target/linux/ipq806x/image/Makefile

index 316e0d3cebabb2e29ddaac16b6867412c7787443..c59e6d446e00d09ec66db9d1240d9a8ff20cbc35 100644 (file)
@@ -74,7 +74,7 @@ define Device/DniImage
        FILESYSTEMS := squashfs
        KERNEL_SUFFIX := -uImage
        KERNEL_INITRAMFS := kernel-bin | append-dtb | uImage none
-       KERNEL = kernel-bin | append-dtb | pad-to $$$$(($$(KERNEL_SIZE)-2*64-1)) | append-file $(KDIR)/root.dummy | uImage none
+       KERNEL = kernel-bin | append-dtb | pad-to $$$$(($$(KERNEL_SIZE)-2*64-1)) | uImage none | append-file $(KDIR)/root.dummy
        KERNEL_NAME := zImage
        NETGEAR_BOARD_ID :=
        NETGEAR_HW_ID :=