toolchain: fix binutils broken symlink
authorFelix Fietkau <nbd@openwrt.org>
Sat, 18 Oct 2014 19:25:24 +0000 (19:25 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 18 Oct 2014 19:25:24 +0000 (19:25 +0000)
The Makefile for binutils creates a broken symlink to "binutils-linaro" in
"trunk/build_dir/toolchain-<target>_gcc-4.9-linaro_uClibc-0.9.33.2".
Modify the Makefile to point the symlink to the correct directory.

Signed-off-by: Nathan Hintz <nlhintz@hotmail.com>
SVN-Revision: 42954

toolchain/binutils/Makefile

index 567f88a8543abb7392e30a91359c98659e0c1cff..b88fbd8b2ca96c04a9f55be085026a4dedaa3fa3 100644 (file)
@@ -63,7 +63,7 @@ endif
 
 define Host/Prepare
        $(call Host/Prepare/Default)
-       ln -snf $(PKG_NAME)-$(PKG_VERSION) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
+       ln -snf $(notdir $(HOST_BUILD_DIR)) $(BUILD_DIR_TOOLCHAIN)/$(PKG_NAME)
        $(CP) $(SCRIPT_DIR)/config.{guess,sub} $(HOST_BUILD_DIR)/
 endef