ar71xx: switch ordering and template to improve readability
authorAlexander Couzens <lynxis@fe80.eu>
Sun, 29 May 2016 00:02:19 +0000 (02:02 +0200)
committerJohn Crispin <john@phrozen.org>
Fri, 27 May 2016 13:55:06 +0000 (15:55 +0200)
The CPE210's ancestor is the CPE510 not the other way around. The device
profile is also named after the CPE510.

Signed-off-by: Alexander Couzens <lynxis@fe80.eu>
target/linux/ar71xx/image/tp-link.mk

index 145fa0f0cdd524a3e46cc4d5f5a5a93abbd86860..140123a4d89bcf0afce0420a7a35631441d78088 100644 (file)
@@ -85,10 +85,10 @@ $(Device/tplink)
   IMAGE_SIZE := 15872k
 endef
 
-define Device/cpe210-220
+define Device/cpe510-520
   MTDPARTS := spi0.0:128k(u-boot)ro,64k(pation-table)ro,64k(product-info)ro,1536k(kernel),6144k(rootfs),192k(config)ro,64k(ART)ro,7680k@0x40000(firmware)
   IMAGE_SIZE := 7680k
-  BOARDNAME := CPE210
+  BOARDNAME := CPE510
   TPLINK_BOARD_NAME := CPE510
   DEVICE_PROFILE := CPE510
   LOADER_TYPE := elf
@@ -98,9 +98,9 @@ define Device/cpe210-220
   IMAGE/factory.bin := append-rootfs | tplink-safeloader factory
 endef
 
-define Device/cpe510-520
-$(Device/cpe210-220)
-  BOARDNAME := CPE510
+define Device/cpe210-220
+$(Device/cpe510-520)
+  BOARDNAME := CPE210
 endef
 TARGET_DEVICES += cpe210-220 cpe510-520