generate vmlinux.srec and vmlinux.bin from srec2bin
authorFlorian Fainelli <florian@openwrt.org>
Thu, 11 Oct 2012 06:45:07 +0000 (06:45 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Thu, 11 Oct 2012 06:45:07 +0000 (06:45 +0000)
Useful for loading the kernel into RAM using ADAM2/PSPBoot.

SVN-Revision: 33718

target/linux/ar7/image/Makefile

index d27c2e888838dfed5c352f14743ee3df679d6ce3..dbd482da198aa698a10b2c26ebe84d350b29d0f6 100644 (file)
@@ -41,7 +41,9 @@ define Image/Prepare
                $(LOADER_MAKEOPTS) \
                clean compile
        $(OBJCOPY_SREC) $(KDIR)/loader.elf $(KDIR)/loader.srec
+       $(OBJCOPY_SREC) $(KDIR)/vmlinux.elf $(KDIR)/vmlinux.srec
        srec2bin $(KDIR)/loader.srec $(KDIR)/loader.bin
+       srec2bin $(KDIR)/vmlinux.srec $(KDIR)/vmlinux.bin
 endef
 
 define align/jffs2-64k