rework aclocal handling, packages have issues writing through the symlink so keep...
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 11 Dec 2010 03:15:10 +0000 (03:15 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 11 Dec 2010 03:15:10 +0000 (03:15 +0000)
SVN-Revision: 24474

include/autotools.mk
package/libtool/Makefile
tools/Makefile

index d5f1e464c0c274cc612eba212146a3d75a16665b..32b512e26c198d2b2d042788a9018bbd7e089b43 100644 (file)
@@ -25,6 +25,7 @@ define autoreconf
                        [ -f ./aclocal.m4 ] && [ ! -f ./acinclude.m4 ] && mv aclocal.m4 acinclude.m4; \
                        [ -d ./autom4te.cache ] && rm -rf autom4te.cache; \
                        $(STAGING_DIR_HOST)/bin/autoreconf -v -f -i -s \
+                               -B $(STAGING_DIR_HOST)/share/aclocal \
                                -B $(STAGING_DIR)/host/share/aclocal \
                                $(patsubst %,-I %,$(PKG_LIBTOOL_PATHS)) $(PKG_LIBTOOL_PATHS) || true; \
                fi \
index 4986f5614eb673fe823951d7c80468ec2254fb89..5aa5aa3652dfb3f13f4c15dba8886c59b436a7a6 100644 (file)
@@ -48,8 +48,6 @@ define Build/InstallDev
        $(SED) 's,\(hardcode_into_libs\)=yes,\1=no,g' $(2)/bin/libtool
        $(CP) $(2)/bin/libtool $(2)/bin/libtool-ucxx
        $(SED) 's,-lstdc++,-luClibc++,g' $(2)/bin/libtool-ucxx
-       [ -h $(STAGING_DIR)/host/share/aclocal ] && \
-               rm -rf $(TMP_DIR)/stage-$(PKG_NAME)/host/share/aclocal || true
 endef
 
 define Package/libltdl/install
index 91f52ff29ac9a51ba36536580ff4dba2614a4287..7f22591dcce5eed689a07b9d37407d7fa4e7c92f 100644 (file)
@@ -65,9 +65,6 @@ endef
 # preparatory work
 $(STAGING_DIR)/.prepared: $(TMP_DIR)/.build $(STAGING_DIR_HOST)/.prepared
        $(call PrepareStaging,$(STAGING_DIR))
-       mkdir -p $(STAGING_DIR)/host/share
-       rm -rf $(STAGING_DIR)/host/share/aclocal
-       ln -s $(STAGING_DIR_HOST)/share/aclocal $(STAGING_DIR)/host/share/
        mkdir -p $(BUILD_DIR)/stamp
        touch $@