ar71xx: add sysupgrade support for wndr4300
authorJohn Crispin <john@openwrt.org>
Wed, 11 Jun 2014 13:00:00 +0000 (13:00 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 11 Jun 2014 13:00:00 +0000 (13:00 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 41131

target/linux/ar71xx/base-files/lib/upgrade/platform.sh
target/linux/ar71xx/image/Makefile

index a6723fab548a600754af6b8a8fdfa6fc0770946d..4e698c6f687f2a62cfc6adb7a8cca1b512d35f54 100755 (executable)
@@ -305,6 +305,14 @@ platform_check_image() {
                }
                return 0
                ;;
+       wndr4300 )
+               nand_do_upgrade_stage1 $board $1
+               [ $? != 0 ] && {
+                       echo "Invalid tar file."
+                       return 1
+               }
+               return 0;
+               ;;
        routerstation | \
        routerstation-pro | \
        ls-sr71 | \
index 924ec665eaa53adbca99ba50d5a68539ee415523..d0ee3637d201882a0bba0b5c359826d915e3eb59 100644 (file)
@@ -877,6 +877,8 @@ define Image/Build/NetgearNAND
                -B $(6) -v OpenWrt.$(REVISION) -r "$$$$r" $(8) \
                -i $(imageraw) \
                -o $(call imgname,ubi,$(2))-factory.img
+
+       $(call Image/Build/SysupgradeNAND,$(2),$(KDIR_TMP)/vmlinux-$(2).uImage,$(KDIR_TMP)/root.squashfs)
 endef