move a stampfile to make it easier to override the patch template
authorFelix Fietkau <nbd@openwrt.org>
Sat, 29 Sep 2007 03:39:57 +0000 (03:39 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 29 Sep 2007 03:39:57 +0000 (03:39 +0000)
SVN-Revision: 9062

include/host-build.mk
include/kernel-defaults.mk
include/package-defaults.mk
include/quilt.mk

index c0d62148e881a79af31044df8caddfc1cdb834bc..e0a2ec1493fc126f223ff1c9c0973bccee973199 100644 (file)
@@ -27,6 +27,7 @@ ifneq ($(strip $(PKG_UNPACK)),)
   define Build/Prepare/Default
        $(PKG_UNPACK)
        $(Build/Patch)
+       $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
   endef
 endif
 
index 7e475660aeb94a05bf610f72c35095229d5bd616..fd5bb1ca061ae655e811dd25cf0ba0ae20e87c03 100644 (file)
@@ -45,6 +45,7 @@ Kernel/Patch:=$(Kernel/Patch/Default)
 define Kernel/Prepare/Default
        bzcat $(DL_DIR)/$(LINUX_SOURCE) | $(TAR) -C $(KERNEL_BUILD_DIR) $(TAR_OPTIONS)
        $(Kernel/Patch)
+       $(if $(QUILT),touch $(LINUX_DIR)/.quilt_used)
 endef
 
 define Kernel/Configure/2.4
index c9f8db10628991d65fdbbf70bee75b45765df18e..50554b3df5141de9b66b0294fcf728a26f055947 100644 (file)
@@ -39,6 +39,7 @@ ifneq ($(strip $(PKG_UNPACK)),)
   define Build/Prepare/Default
        $(PKG_UNPACK)
        $(Build/Patch)
+       $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
   endef
 endif
 
index aa0eda69194e533d8d003c66f33acf95cb9fa4d2..8554f19c7f215595a5ca4339cf54e0dec5337709 100644 (file)
@@ -59,7 +59,6 @@ endif
 define Build/Patch/Default
        $(if $(QUILT),rm -rf $(PKG_BUILD_DIR)/patches; mkdir -p $(PKG_BUILD_DIR)/patches)
        $(call PatchDir,$(PATCH_DIR),)
-       $(if $(QUILT),touch $(PKG_BUILD_DIR)/.quilt_used)
 endef
 
 define Kernel/Patch/Default
@@ -68,7 +67,6 @@ define Kernel/Patch/Default
        if [ -d ./files ]; then $(CP) ./files/* $(LINUX_DIR)/; fi
        $(call PatchDir,$(GENERIC_PATCH_DIR),generic/)
        $(call PatchDir,$(PATCH_DIR),platform/)
-       $(if $(strip $(QUILT)),touch $(PKG_BUILD_DIR)/.quilt_used)
 endef
 
 $(STAMP_PATCHED): $(STAMP_PREPARED)