allow overriding BIN_DIR (#7412)
authorJo-Philipp Wich <jow@openwrt.org>
Tue, 26 Oct 2010 14:15:52 +0000 (14:15 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Tue, 26 Oct 2010 14:15:52 +0000 (14:15 +0000)
SVN-Revision: 23643

target/imagebuilder/files/Makefile

index 469c4a2dd28308c2f172e7423c3f4b4143e9d107..1fa074b35ea268535c635fed2153a77db3a5584f 100644 (file)
@@ -42,6 +42,7 @@ Building images:
        make image PROFILE="<profilename>" # override the default target profile
        make image PACKAGES="<pkg1> [<pkg2> [<pkg3> ...]]" # include extra packages
        make image FILES="<path>" # include extra files from <path>
+       make image BIN_DIR="<path>" # alternative output directory for the images
 
 endef
 $(eval $(call shexport,Helptext))
@@ -157,7 +158,8 @@ image:
        $(MAKE) _call_image \
                $(if $(PROFILE),USER_PROFILE="$(PROFILE)") \
                $(if $(FILES),USER_FILES="$(FILES)") \
-               $(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)"))
+               $(if $(PACKAGES),USER_PACKAGES="$(PACKAGES)") \
+               $(if $(BIN_DIR),BIN_DIR="$(BIN_DIR)"))
 
 .SILENT: help info image