uboot-envtools: add support for oxnas target
authorJohn Crispin <john@openwrt.org>
Wed, 26 Nov 2014 09:00:40 +0000 (09:00 +0000)
committerJohn Crispin <john@openwrt.org>
Wed, 26 Nov 2014 09:00:40 +0000 (09:00 +0000)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
SVN-Revision: 43390

package/boot/uboot-envtools/Makefile
package/boot/uboot-envtools/files/oxnas [new file with mode: 0644]

index fa49c13f967dbfe8505641e99c37ea44b2ae6bd7..1db290eeb2c997aeab054ac8d8ac34ddd1aade23 100644 (file)
@@ -94,6 +94,10 @@ ifneq ($(CONFIG_TARGET_mxs),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_BIN) ./files/mxs $(1)/etc/uci-defaults/30_uboot-envtools
 endif
+ifneq ($(CONFIG_TARGET_oxnas),)
+       $(INSTALL_DIR) $(1)/etc/uci-defaults
+       $(INSTALL_BIN) ./files/oxnas $(1)/etc/uci-defaults/30_uboot-envtools
+endif
 ifneq ($(CONFIG_TARGET_ramips),)
        $(INSTALL_DIR) $(1)/etc/uci-defaults
        $(INSTALL_DATA) ./files/ramips $(1)/etc/uci-defaults/30_uboot-envtools
diff --git a/package/boot/uboot-envtools/files/oxnas b/package/boot/uboot-envtools/files/oxnas
new file mode 100644 (file)
index 0000000..b456fb3
--- /dev/null
@@ -0,0 +1,29 @@
+#!/bin/sh
+#
+# Copyright (C) 2013 OpenWrt.org
+#
+
+[ -e /etc/config/ubootenv ] && exit 0
+
+touch /etc/config/ubootenv
+
+. /lib/oxnas.sh
+. /lib/uboot-envtools.sh
+. /lib/functions.sh
+
+board=$(oxnas_board_name)
+
+case "$board" in
+stg212)
+       ubootenv_add_uci_config "/dev/ubi0_0" "0x0" "0x4000" "0x1F000" "1"
+       ubootenv_add_uci_config "/dev/ubi0_1" "0x0" "0x4000" "0x1F000" "1"
+       ;;
+kd20)
+       ubootenv_add_uci_config "/dev/mtd0" "0x220000" "0x02000" "0x20000" "1"
+       ;;
+esac
+
+config_load ubootenv
+config_foreach ubootenv_add_app_config ubootenv
+
+exit 0