odhcp6c: add preliminary support for MAP provisioning
authorSteven Barth <cyrus@openwrt.org>
Wed, 30 Apr 2014 15:52:30 +0000 (15:52 +0000)
committerSteven Barth <cyrus@openwrt.org>
Wed, 30 Apr 2014 15:52:30 +0000 (15:52 +0000)
SVN-Revision: 40604

package/network/ipv6/odhcp6c/Makefile
package/network/ipv6/odhcp6c/files/dhcpv6.script
package/network/ipv6/odhcp6c/files/dhcpv6.sh

index cebb62422a49a5865a1a0d61cf3554612bae618e..e8bdbded42c513d04c94f5f842dece98a710afc8 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=odhcp6c
-PKG_VERSION:=2014-04-09
+PKG_VERSION:=2014-04-30
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
 PKG_SOURCE_URL:=git://github.com/sbyx/odhcp6c.git
 PKG_SOURCE_PROTO:=git
-PKG_SOURCE_VERSION:=6bbd2b0208fc17b6566595bfdfef2ff1d012d143
+PKG_SOURCE_VERSION:=a0bbaf5bffc66b1693577a374a9a599e313aefe1
 PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
 
 include $(INCLUDE_DIR)/package.mk
@@ -29,6 +29,10 @@ ifneq ($(CONFIG_PACKAGE_odhcp6c_ext_cer_id),0)
   CMAKE_OPTIONS += -DEXT_CER_ID=$(CONFIG_PACKAGE_odhcp6c_ext_cer_id)
 endif
 
+ifneq ($(CONFIG_PACKAGE_odhcp6c_ext_s46),0)
+  CMAKE_OPTIONS += -DEXT_S46=$(CONFIG_PACKAGE_odhcp6c_ext_s46)
+endif
+
 define Package/odhcp6c
   SECTION:=net
   CATEGORY:=Network
@@ -46,6 +50,11 @@ define Package/odhcp6c/config
     int "CER-ID Extension ID (0 = disabled)"
     depends on PACKAGE_odhcp6c
     default 0
+
+  config PACKAGE_odhcp6c_ext_s46
+    int "Softwire MAP Extension ID (0 = disabled)"
+    depends on PACKAGE_odhcp6c
+    default 0
 endef
 
 define Package/odhcp6c/install
index d228014dd423ef74111492caa3b43c882c68e9d6..3599284d80f1f22af8e25c0395ad8db1939c90b9 100755 (executable)
@@ -94,6 +94,33 @@ setup_interface () {
                ubus call network add_dynamic "$(json_dump)"
        fi
 
+       MAPTYPE=""
+       MAPRULE=""
+
+       if [ -n "$MAPE" ]; then
+               MAPTYPE="map-e"
+               MAPRULE="$MAPE"
+       elif [ -n "$MAPT" ]; then
+               MAPTYPE="map-t"
+               MAPRULE="$MAPT"
+       elif [ -n "$LW4O6" ]; then
+               MAPTYPE="lw4o6"
+               MAPRULE="$LW4O6"
+       fi
+
+       if [ -n "$IFACE_MAP" -a -n "$MAPTYPE" -a -n "$MAPRULE" ]; then
+               json_init
+               json_add_string name "$IFACE_MAP"
+               json_add_string ifname "@$INTERFACE"
+               json_add_string proto map
+               json_add_string type "$MAPTYPE"
+               json_add_string rule "$MAPRULE"
+               [ -n "$ZONE_MAP" ] && json_add_string zone "$ZONE_MAP"
+               [ -n "$IFACE_MAP_DELEGATE" ] && json_add_boolean delegate "$IFACE_MAP_DELEGATE"
+               json_close_object
+               ubus call network add_dynamic "$(json_dump)"
+       fi
+
        # TODO: $SNTP_IP $SIP_IP $SNTP_FQDN $SIP_DOMAIN
 }
 
index 90a83718e527120d5b0f33c450f4db47ad7492d0..226ca76d049b914bc5ac26f8f2a878210dbeaffc 100755 (executable)
@@ -17,6 +17,8 @@ proto_dhcpv6_init_config() {
        proto_config_add_string 'ip6prefix:ip6addr'
        proto_config_add_string iface_dslite
        proto_config_add_string zone_dslite
+       proto_config_add_string iface_map
+       proto_config_add_string zone_map
        proto_config_add_string 'ifaceid:ip6addr'
        proto_config_add_string 'sourcerouting:bool'
        proto_config_add_string "userclass"
@@ -28,8 +30,8 @@ proto_dhcpv6_setup() {
        local config="$1"
        local iface="$2"
 
-       local reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid sourcerouting userclass vendorclass delegate zone_dslite
-       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite ifaceid sourcerouting userclass vendorclass delegate zone_dslite
+       local reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite iface_map ifaceid sourcerouting userclass vendorclass delegate zone_dslite zone_map
+       json_get_vars reqaddress reqprefix clientid reqopts noslaaconly forceprefix norelease ip6prefix iface_dslite iface_map ifaceid sourcerouting userclass vendorclass delegate zone_dslite zone_map
 
 
        # Configure
@@ -59,9 +61,12 @@ proto_dhcpv6_setup() {
 
        [ -n "$ip6prefix" ] && proto_export "USERPREFIX=$ip6prefix"
        [ -n "$iface_dslite" ] && proto_export "IFACE_DSLITE=$iface_dslite"
+       [ -n "$iface_map" ] && proto_export "IFACE_MAP=$iface_map"
        [ "$sourcerouting" != "0" ] && proto_export "SOURCE_ROUTING=1"
        [ "$delegate" = "0" ] && proto_export "IFACE_DSLITE_DELEGATE=0"
+       [ "$delegate" = "0" ] && proto_export "IFACE_MAP_DELEGATE=0"
        [ -n "$zone_dslite" ] && proto_export "ZONE_DSLITE=$zone_dslite"
+       [ -n "$zone_map" ] && proto_export "ZONE_MAP=$zone_map"
 
        proto_export "INTERFACE=$config"
        proto_run_command "$config" odhcp6c \