procd: add support for relaying daemon stdio to syslog
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 26 Feb 2015 13:42:47 +0000 (13:42 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 26 Feb 2015 13:42:47 +0000 (13:42 +0000)
Procd enabled init scripts can now specify:

  procd_set_param stdout 1
  procd_set_param stderr 1

... to relay their respective standard IO streams to the system log.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 44547

package/system/procd/Makefile
package/system/procd/files/procd.sh

index f31195910dca1481c90cb578c8004ff29c96c97b..ba1077492d2ab6d820fe854510fbafb68df253d0 100644 (file)
@@ -8,14 +8,14 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=procd
-PKG_VERSION:=2015-02-26
+PKG_VERSION:=2015-02-26.1
 
 PKG_RELEASE=$(PKG_SOURCE_VERSION)
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=git://nbd.name/luci2/procd.git
 PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
-PKG_SOURCE_VERSION:=4bccbfa967d756b8c84a62ea4752e936d8545a73
+PKG_SOURCE_VERSION:=9851e517f1c3e55228e2fdde913c9cf0b87a4bc7
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION)-$(PKG_SOURCE_VERSION).tar.gz
 CMAKE_INSTALL:=1
 
index be1d888a196e429776211e184903f736f0364e1e..78352c0b761a07bd4c7f40806d485e7c790019c4 100644 (file)
@@ -143,6 +143,9 @@ _procd_set_param() {
                user)
                        json_add_string "$type" "$1"
                ;;
+               stdout|stderr)
+                       json_add_boolean "$type" "$1"
+               ;;
        esac
 }