ar71xx: move DomyWifi DW33D to nand subtarget
[openwrt/staging/mkresin.git] / target / linux / ar71xx / image / nand.mk
index aa43a91ee97fb2cf8e802d0214f387c1f16a040f..cf4c286bee1b662b2049aaa63cb1e9e2b7d36c05 100644 (file)
@@ -13,6 +13,17 @@ endef
 
 TARGET_DEVICES += c-60
 
+define Device/domywifi-dw33d
+  DEVICE_TITLE := DomyWifi DW33D
+  DEVICE_PACKAGES := kmod-usb-core kmod-usb2 kmod-usb-storage kmod-usb-ledtrig-usbport kmod-ath10k
+  BOARDNAME = DW33D
+  IMAGE_SIZE = 16000k
+  CONSOLE = ttyS0,115200
+  MTDPARTS = spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,14528k(rootfs),1472k(kernel),64k(art)ro,16000k@0x50000(firmware);ar934x-nfc:96m(rootfs_data),32m(backup)ro
+  IMAGE/sysupgrade.bin = append-rootfs | pad-rootfs | pad-to 14528k | append-kernel | check-size $$$$(IMAGE_SIZE)
+endef
+TARGET_DEVICES += domywifi-dw33d
+
 define Build/MerakiNAND
        -$(STAGING_DIR_HOST)/bin/mkmerakifw \
                -B $(BOARDNAME) -s \