add some changes from whiterussian to head
authorFelix Fietkau <nbd@openwrt.org>
Sat, 16 Jul 2005 10:18:01 +0000 (10:18 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Sat, 16 Jul 2005 10:18:01 +0000 (10:18 +0000)
SVN-Revision: 1455

openwrt/package/kismet/Config.in
openwrt/package/kismet/Makefile
openwrt/package/kismet/ipkg/kismet.control [new file with mode: 0644]
openwrt/target/default/target_skeleton/etc/init.d/S10boot
openwrt/target/default/target_skeleton/etc/init.d/S45firewall
openwrt/target/default/target_skeleton/etc/nvram.overrides
openwrt/target/linux/image/squashfs.mk

index 5650ad669afbe38a80743e456353982ed2bc466b..d3708d78e1e17b87043e94458b5b6072b3d97fa6 100644 (file)
@@ -1,7 +1,7 @@
 menu "kismet - an 802.11 layer2 wireless network detector, sniffer, and intrusion detection system"
 
 config BR2_PACKAGE_KISMET
-       bool
+       tristate
        default n
        depends BR2_PACKAGE_KISMET_CLIENT || BR2_PACKAGE_KISMET_DRONE || BR2_PACKAGE_KISMET_SERVER
 
index 0f9c0cd26edbf4971f271e08bc80fa350ae78baa..e1ee6c27cdf9e03c70cd82ed7d79a59bf4c3d637 100644 (file)
@@ -16,6 +16,7 @@ PKG_INSTALL_DIR:=$(PKG_BUILD_DIR)/ipkg-install
 
 include $(TOPDIR)/package/rules.mk
 
+$(eval $(call PKG_template,KISMET,kismet,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,KISMET_CLIENT,kismet-client,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,KISMET_DRONE,kismet-drone,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
 $(eval $(call PKG_template,KISMET_SERVER,kismet-server,$(PKG_VERSION)-$(PKG_RELEASE),$(ARCH)))
@@ -59,6 +60,11 @@ $(PKG_BUILD_DIR)/.built:
                CPPFLAGS="-I$(STAGING_DIR)/include -I$(STAGING_DIR)/usr/include -I$(LINUX_DIR)/include" 
        touch $@
 
+$(IPKG_KISMET):
+       install -d -m0755 $(IDIR_KISMET)/usr/bin/
+       cp -fpR $(PKG_BUILD_DIR)/scripts/kismet $(IDIR_KISMET)/usr/bin/
+       $(IPKG_BUILD) $(IDIR_KISMET) $(PACKAGE_DIR)
+
 $(IPKG_KISMET_CLIENT):
        install -d -m0755 $(IDIR_KISMET_CLIENT)/etc/kismet/
        install -m0644 ./files/ap_manuf $(IDIR_KISMET_CLIENT)/etc/kismet/
diff --git a/openwrt/package/kismet/ipkg/kismet.control b/openwrt/package/kismet/ipkg/kismet.control
new file mode 100644 (file)
index 0000000..dc0676f
--- /dev/null
@@ -0,0 +1,11 @@
+Package: kismet
+Priority: optional
+Section: net
+Maintainer: Felix Fietkau <nbd@vd-s.ath.cx>
+Source: buildroot internal
+Depends: kismet-client, kismet-server 
+Description: kismet
+ Kismet is an 802.11 layer2 wireless network detector,
+ sniffer, and intrusion detection system. Kismet will work with any
+ wireless card which supports raw monitoring (rfmon) mode, and can
+ sniff 802.11b, 802.11a, and 802.11g traffic. 
index f45eafb1e7096f8ac1439f0f13fd6e2d5db6a3df..22096d5fbb3554a3a20afb116933afd91bde2c65 100755 (executable)
@@ -14,16 +14,14 @@ touch /var/log/lastlog
 
 # set up the vlan*ports variables for the asus wl-500g deluxe
 # if they don't already exist 
-[ "$(nvram get boardtype)" = "bcm95365r" ] && \
-[ "$(nvram get boardnum)" = "45" ] && {
-  [ -z "$(nvram get vlan0ports)" ] && \
-  [ -z "$(nvram get vlan1ports)" ] && {
-    nvram set vlan0ports="1 2 3 4 5*"
-    nvram set vlan1ports="0 5"
-  }
+[  "$(nvram get boardtype)" = "bcm95365r" \
+-a "$(nvram get boardnum)" = "45" \
+-a -z "$(nvram get vlan0ports)$(nvram get vlan1ports)" ] && {
+       nvram set vlan0ports="1 2 3 4 5*"
+       nvram set vlan1ports="0 5"
 }
 
-cat /etc/modules /etc/modules.d/*|sed 's/^[^#]/insmod &/' 2>&-|ash
+sed 's/^[^#]/insmod &/' /etc/modules /etc/modules.d/* 2>&-|ash
 
 ifconfig lo 127.0.0.1 up
 ifconfig eth0 promisc
index dc429f27254290f1065f588109e479c0f6eb863e..8350ccbfefa1f5dd6c0b41f988a7a4f71a8707c0 100755 (executable)
@@ -26,7 +26,7 @@ iptables -t nat -N postrouting_rule
   iptables -P INPUT DROP
   iptables -A INPUT -m state --state INVALID -j DROP
   iptables -A INPUT -m state --state RELATED,ESTABLISHED -j ACCEPT
-  iptables -A INPUT -p tcp --syn --tcp-option \! 2 -j  DROP
+  iptables -A INPUT -p tcp --tcp-flags SYN SYN --tcp-option \! 2 -j  DROP
 
   #
   # insert accept rule or to jump to new accept-check table here
index 001a61329e1ab752246e56d008a8a49dcfe91fef..d457af48ee33e8b72f3959f56ab4c18e830f6c66 100644 (file)
@@ -20,8 +20,8 @@ remap () {
 }
 
 # hacks for wrt54g 1.x hardware
-[ "$(nvram get boardnum)"  = "42" ] && \
-[ "$(nvram get boardtype)" = "bcm94710dev" ] && {
+[  "$(nvram get boardnum)"  = "42" \
+-a "$(nvram get boardtype)" = "bcm94710dev" ] && {
   debug "### wrt54g 1.x hack ###"
   NVRAM_vlan1hwname="et0"
   NVRAM_vlan2hwname="et0"
@@ -31,8 +31,8 @@ remap () {
 }
 
 # hacks for asus wl-500g deluxe
-[ "$(nvram get boardtype)" = "bcm95365r" ] && \
-[ "$(nvram get boardnum)" = "45" ] && {
+[  "$(nvram get boardtype)" = "bcm95365r" \
+-a "$(nvram get boardnum)" = "45" ] && {
   debug "### wl-500g deluxe hacks ###"
   NVRAM_vlan0hwname="et0"
   NVRAM_vlan1hwname="et0"
@@ -42,32 +42,32 @@ remap () {
 }
 
 # hacks for asus wl-300g
-[ "$(nvram get productid)"  = "WL300g" ] && {
+[ "$(nvram get productid)" = "WL300g" ] && {
   debug "### wl-300g hacks ###"
   NVRAM_lan_ifnames="eth0 eth2"
   NVRAM_wan_ifname="none"
 }
 
 # hacks for wap54g hardware
-[ "$(nvram get boardnum)"  = "2" ] || \
-[ "$(nvram get boardnum)"  = "1024" ] && {
+[  "$(nvram get boardnum)" = "2" \
+-o "$(nvram get boardnum)" = "1024" ] && {
   debug "### wap54g hack ###"
   NVRAM_wan_ifname="none"
   FAILSAFE_ifnames="eth0 eth1"
 }
 
 # hacks for buffalo wla2-g54l
-[ "$(nvram get boardnum)" = "00" ] && \
-[ "$(nvram get product_name)" = "Product_name" ] || \
-[ "$(nvram get product_name)" = "WLA2-G54L" ] && {
+[  "$(nvram get boardnum)" = "00" \
+-a "$(nvram get product_name)" = "Product_name" \
+-o "$(nvram get product_name)" = "WLA2-G54L" ] && {
   debug "### wla2-g54l hacks ###"
   NVRAM_wan_ifname="none"
   NVRAM_lan_ifnames="vlan0"
 }
 
 # hack for asus wl-500g hardware
-[ "$(nvram get boardnum)"  = "asusX" ] && \
-[ "$(nvram get boardtype)"  = "bcm94710dev" ] && {
+[  "$(nvram get boardnum)"  = "asusX" \
+-a "$(nvram get boardtype)"  = "bcm94710dev" ] && {
   FAILSAFE_ifnames="eth0 eth2"
 }
 
index 917a69ab8a1bbc5f652b83ce687b0b31db1b0f3c..70a85b99ee7445329e5f401c46b9f7707fda0e2c 100644 (file)
@@ -10,7 +10,7 @@ squashfs-clean:
 
 $(KDIR)/root.squashfs:
        @mkdir -p $(KDIR)/root/jffs
-       $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -noappend -root-owned -le
+       $(STAGING_DIR)/bin/mksquashfs-lzma $(KDIR)/root $@ -nopad -noappend -root-owned -le
 
 squashfs-install: $(KDIR)/root.squashfs
        $(MAKE) -C $(BOARD) install KERNEL="$(KERNEL)" FS="squashfs"