uhttpd: clear script timeout as soon as data is received from the child
authorJo-Philipp Wich <jow@openwrt.org>
Sat, 27 Mar 2010 01:47:36 +0000 (01:47 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sat, 27 Mar 2010 01:47:36 +0000 (01:47 +0000)
SVN-Revision: 20501

package/uhttpd/Makefile
package/uhttpd/src/uhttpd-cgi.c
package/uhttpd/src/uhttpd-lua.c

index 3e7344911b5dc1bd957c7dccc547620439ca1090..d5c4aa6252800313a0363c32e0d241256a1526ee 100644 (file)
@@ -8,7 +8,7 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=uhttpd
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_BUILD_DIR := $(BUILD_DIR)/$(PKG_NAME)
 
index 4a30f2fc9a70677c64468c56ab06c5169affc785..8bd22503de3d5c66f09dc11fbf1bb926a449006e 100644 (file)
@@ -360,6 +360,9 @@ void uh_cgi_request(struct client *cl, struct http_request *req, struct path_inf
 
                        memset(hdr, 0, sizeof(hdr));
 
+                       timeout.tv_sec = cl->server->conf->script_timeout;
+                       timeout.tv_usec = 0;
+
 #define ensure(x) \
        do { if( x < 0 ) goto out; } while(0)
 
@@ -372,12 +375,11 @@ void uh_cgi_request(struct client *cl, struct http_request *req, struct path_inf
                                FD_SET(rfd[0], &reader);
                                FD_SET(wfd[1], &writer);
 
-                               timeout.tv_sec = cl->server->conf->script_timeout;
-                               timeout.tv_usec = 0;
-
                                /* wait until we can read or write or both */
-                               if( select(fd_max, &reader, (content_length > -1) ? &writer : NULL, NULL, &timeout) > 0 )
-                               {
+                               if( select(fd_max, &reader,
+                                       (content_length > -1) ? &writer : NULL, NULL,
+                                       (header_sent < 1) ? &timeout : NULL) > 0
+                               ) {
                                        /* ready to write to cgi program */
                                        if( FD_ISSET(wfd[1], &writer) )
                                        {
index c1e749043864507a449f9b5047e62864a3bd07d7..fcbdc6482543864e41937450fd79c51eb564a130 100644 (file)
@@ -439,6 +439,9 @@ void uh_lua_request(struct client *cl, struct http_request *req, lua_State *L)
 
                        data_sent = 0;
 
+                       timeout.tv_sec = cl->server->conf->script_timeout;
+                       timeout.tv_usec = 0;
+
                        /* I/O loop, watch our pipe ends and dispatch child reads/writes from/to socket */
                        while( 1 )
                        {
@@ -448,12 +451,11 @@ void uh_lua_request(struct client *cl, struct http_request *req, lua_State *L)
                                FD_SET(rfd[0], &reader);
                                FD_SET(wfd[1], &writer);
 
-                               timeout.tv_sec = cl->server->conf->script_timeout;
-                               timeout.tv_usec = 0;
-
                                /* wait until we can read or write or both */
-                               if( select(fd_max, &reader, (content_length > -1) ? &writer : NULL, NULL, &timeout) > 0 )
-                               {
+                               if( select(fd_max, &reader,
+                                   (content_length > -1) ? &writer : NULL, NULL,
+                                       (data_sent < 1) ? &timeout : NULL) > 0
+                               ) {
                                        /* ready to write to Lua child */
                                        if( FD_ISSET(wfd[1], &writer) )
                                        {