ar71xx: expand kernel size for ubnt targets
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 29 Oct 2018 14:48:10 +0000 (15:48 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Mon, 29 Oct 2018 15:20:47 +0000 (16:20 +0100)
Kernel 4.14 is pretty large causing a build error as the partition is too small.
Expand the kernel partition a bit to make it fit.

* ubnt-uap-pro
* ubnt-unifi-outdoor-plus

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
target/linux/ar71xx/image/generic-ubnt.mk

index b9ce32bd3fb0ee3e52929da3b8c9ae3a42bcd8c3..6941012cbe6ac249af8e53b3b8f823378a8da670 100644 (file)
@@ -259,9 +259,9 @@ TARGET_DEVICES += ubnt-ls-sr71
 
 define Device/ubnt-uap-pro
   DEVICE_TITLE := Ubiquiti UAP Pro
-  KERNEL_SIZE := 1792k
+  KERNEL_SIZE := 2048k
   IMAGE_SIZE := 15744k
-  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,1792k(kernel),13952k(rootfs),256k(cfg)ro,64k(EEPROM)ro,15744k@0x50000(firmware)
+  MTDPARTS := spi0.0:256k(u-boot)ro,64k(u-boot-env)ro,2048k(kernel),13696k(rootfs),256k(cfg)ro,64k(EEPROM)ro,15744k@0x50000(firmware)
   UBNT_TYPE := BZ
   UBNT_CHIP := ar934x
   BOARDNAME := UAP-PRO