bcm53xx: add default config for switch
authorHauke Mehrtens <hauke@hauke-m.de>
Wed, 23 Apr 2014 22:02:18 +0000 (22:02 +0000)
committerHauke Mehrtens <hauke@hauke-m.de>
Wed, 23 Apr 2014 22:02:18 +0000 (22:02 +0000)
This scripts adds a default config for the switch.

Signed-off-by: Hauke Mehrtens <hauke@hauke-m.de>
SVN-Revision: 40565

target/linux/bcm53xx/base-files.mk [new file with mode: 0644]
target/linux/bcm53xx/base-files/etc/uci-defaults/02_network [new file with mode: 0644]

diff --git a/target/linux/bcm53xx/base-files.mk b/target/linux/bcm53xx/base-files.mk
new file mode 100644 (file)
index 0000000..fdd2c71
--- /dev/null
@@ -0,0 +1,3 @@
+define Package/base-files/install-target
+       rm -f $(1)/etc/config/network
+endef
diff --git a/target/linux/bcm53xx/base-files/etc/uci-defaults/02_network b/target/linux/bcm53xx/base-files/etc/uci-defaults/02_network
new file mode 100644 (file)
index 0000000..7517d07
--- /dev/null
@@ -0,0 +1,21 @@
+#!/bin/sh
+#
+# Copyright (C) 2011 OpenWrt.org
+#
+
+[ -e /etc/config/network ] && exit 0
+
+touch /etc/config/network
+
+. /lib/functions/uci-defaults.sh
+
+ucidef_set_interface_loopback
+
+ucidef_set_interfaces_lan_wan "eth0.1" "eth0.2"
+ucidef_add_switch "switch0" "1" "1"
+ucidef_add_switch_vlan "switch0" "1" "0 1 2 3 5t"
+ucidef_add_switch_vlan "switch0" "2" "4 5t"
+
+uci commit network
+
+exit 0