add AX25 support (thanks to Michael Conrad)
authorNicolas Thill <nico@openwrt.org>
Thu, 20 Oct 2005 05:41:23 +0000 (05:41 +0000)
committerNicolas Thill <nico@openwrt.org>
Thu, 20 Oct 2005 05:41:23 +0000 (05:41 +0000)
SVN-Revision: 2189

openwrt/target/linux/Config.in
openwrt/target/linux/control/kmod-ax25.control [new file with mode: 0644]
openwrt/target/linux/linux-2.4/Makefile
openwrt/target/linux/linux-2.4/config/brcm
openwrt/target/linux/linux-2.4/config/soekris

index f59ba787a88630076f8b5618079ce2ecadf070dc..69f96c48d12ce81db6478c70c4e337e1a77350b0 100644 (file)
@@ -130,6 +130,14 @@ config BR2_PACKAGE_KMOD_IPTABLES_V4
        help
          Kernel modules for IPv4 firewalling
 
+config BR2_PACKAGE_KMOD_AX25
+       tristate "AX25 support"
+       default m
+       help
+         Kernel modules for AX25 protocol family
+          - ax25.o: AX25 layer 2 support
+          - mkiss.o: AX25 KISS driver
+
 config BR2_PACKAGE_KMOD_IPTABLES_V4_EXTRA
        tristate "Extra modules for iptables"
        default m
diff --git a/openwrt/target/linux/control/kmod-ax25.control b/openwrt/target/linux/control/kmod-ax25.control
new file mode 100644 (file)
index 0000000..c080d45
--- /dev/null
@@ -0,0 +1,6 @@
+Package: kmod-ax25
+Priority: optional
+Section: net
+Maintainer: Michael Conrad <openwrt@friggleware.net>
+Source: buildroot internal
+Description: Kernel AX25 driver
index 9c56a0b2b4bf65158b1c6de8412fc3b744de1ed4..ede1e7a9857428abf77578bb71e076c84efd8884 100644 (file)
@@ -193,6 +193,10 @@ $(eval $(call KMOD_template,VIDEODEV,videodev,\
 $(eval $(call KMOD_template,PWC,pwc,\
        $(MODULES_DIR)/kernel/drivers/usb/pwc.o \
 ,CONFIG_USB_PWC))
+$(eval $(call KMOD_template,AX25,ax25,\
+       $(MODULES_DIR)/kernel/net/ax25/ax25.o \
+       $(MODULES_DIR)/kernel/drivers/net/hamradio/mkiss.o \
+,CONFIG_AX25))
 
 $(TARGETS): $(PACKAGE_DIR)
 
@@ -230,7 +234,7 @@ $(LINUX_DIR)/vmlinux: $(LINUX_DIR)/.depend_done
 $(LINUX_KERNEL): $(LINUX_DIR)/vmlinux
        $(TARGET_CROSS)objcopy -O binary -R .reginfo -R .note -R .comment -R .mdebug -S $< $@ 
        touch -c $(LINUX_KERNEL)
-       
+
 $(LINUX_DIR)/.modules_done: $(LINUX_KERNEL) $(LINUX_IMAGE)
        rm -rf $(LINUX_BUILD_DIR)/modules
        $(MAKE) -C $(LINUX_DIR) ARCH=$(LINUX_KARCH) PATH=$(TARGET_PATH) modules
index 871cbdc6a263b95eeed02bfe7d77cb8b4ad07b70..f970cfe82476540dab0daa2c6bacc2372cba8be9 100644 (file)
@@ -849,7 +849,30 @@ CONFIG_SHAPER=m
 #
 # Amateur Radio support
 #
-# CONFIG_HAMRADIO is not set
+#
+# Amateur Radio support
+#
+CONFIG_HAMRADIO=y
+CONFIG_AX25=m
+# CONFIG_AX25_DAMA_SLAVE is not set
+# CONFIG_NETROM is not set
+# CONFIG_ROSE is not set
+
+#
+# AX.25 network device drivers
+#
+CONFIG_MKISS=m
+# CONFIG_6PACK is not set
+# CONFIG_BPQETHER is not set
+# CONFIG_DMASCC is not set
+# CONFIG_SCC is not set
+# CONFIG_BAYCOM_SER_FDX is not set
+# CONFIG_BAYCOM_SER_HDX is not set
+# CONFIG_BAYCOM_PAR is not set
+# CONFIG_BAYCOM_EPP is not set
+# CONFIG_SOUNDMODEM is not set
+# CONFIG_YAM is not set
+
 
 #
 # IrDA (infrared) support
index a3d9286a71ae0c7780ec78639433d4a41a8b3a51..92892b180eb650e90478c7c8ce265c0d9aa610d4 100644 (file)
@@ -807,7 +807,27 @@ CONFIG_NET_PCMCIA=y
 #
 # Amateur Radio support
 #
-# CONFIG_HAMRADIO is not set
+CONFIG_HAMRADIO=y
+CONFIG_AX25=m
+# CONFIG_AX25_DAMA_SLAVE is not set
+# CONFIG_NETROM is not set
+# CONFIG_ROSE is not set
+
+#
+# AX.25 network device drivers
+#
+CONFIG_MKISS=m
+# CONFIG_6PACK is not set
+# CONFIG_BPQETHER is not set
+# CONFIG_DMASCC is not set
+# CONFIG_SCC is not set
+# CONFIG_BAYCOM_SER_FDX is not set
+# CONFIG_BAYCOM_SER_HDX is not set
+# CONFIG_BAYCOM_PAR is not set
+# CONFIG_BAYCOM_EPP is not set
+# CONFIG_SOUNDMODEM is not set
+# CONFIG_YAM is not set
+
 
 #
 # IrDA (infrared) support