libcxx: Build with the libsupc++ ABI
authorRosen Penev <rosenp@gmail.com>
Wed, 1 Jan 2020 03:37:34 +0000 (19:37 -0800)
committerJo-Philipp Wich <jo@mein.io>
Wed, 1 Jan 2020 15:59:13 +0000 (16:59 +0100)
Allows proper exception handling. This includes removing unimplemented
warnings.

File size increased as a result:

Before:

182874

After:

211006

On mipsel_24kc.

Note that this requires libsupc++ anyway. It's specified in g++-libcxx.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
package/libs/libcxx/Makefile

index 695b0398feade39800ccf8465ec0b3de202d4c4c..60978bdc316ab4f2f758ae1b97d625d7e9360c4b 100644 (file)
@@ -7,7 +7,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=libcxx
 PKG_VERSION:=9.0.1
-PKG_RELEASE:=2
+PKG_RELEASE:=3
 
 PKG_SOURCE_PROTO:=git
 PKG_SOURCE_URL:=https://git.llvm.org/git/libcxx
@@ -37,6 +37,7 @@ define Package/libcxx/description
 endef
 
 CMAKE_OPTIONS += \
+       -DLIBCXX_CXX_ABI="libsupc++" \
        -DLIBCXX_ENABLE_ASSERTIONS=OFF \
        -DLIBCXX_ENABLE_EXPERIMENTAL_LIBRARY=OFF \
        -DLIBCXX_INCLUDE_BENCHMARKS=OFF \