kernel/modules: add kmod-crypto-aead
authorFelix Fietkau <nbd@openwrt.org>
Mon, 5 Jan 2015 13:01:23 +0000 (13:01 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 5 Jan 2015 13:01:23 +0000 (13:01 +0000)
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
SVN-Revision: 43830

package/kernel/linux/modules/crypto.mk

index de3d8514428d05af59896191c0034eede80cef50..ad1fe4e723e8fee56b8f76ab7d177200bd8a16d3 100644 (file)
@@ -39,6 +39,19 @@ define AddDepends/crypto
   DEPENDS+=+kmod-crypto-core $(1)
 endef
 
+define KernelPackage/crypto-aead
+  TITLE:=CryptoAPI AEAD support
+  KCONFIG:= \
+       CONFIG_CRYPTO_AEAD \
+       CONFIG_CRYPTO_AEAD2
+  FILES:=$(LINUX_DIR)/crypto/aead.ko
+  AUTOLOAD:=$(call AutoLoad,09,crypto_aead,1)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-aead))
+
+
 define KernelPackage/crypto-hash
   TITLE:=CryptoAPI hash support
   KCONFIG:=CONFIG_CRYPTO_HASH