package/kernel: move block2mtd to block.mk
authorNicolas Thill <nico@openwrt.org>
Sat, 24 Apr 2010 13:45:05 +0000 (13:45 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 24 Apr 2010 13:45:05 +0000 (13:45 +0000)
SVN-Revision: 21134

package/kernel/modules/block.mk
package/kernel/modules/other.mk

index ebd5d4ddef35293a2c7b66dec186cfd8190acf9b..f1074251abb41c427c479dce2f0f4daa989f4c86 100644 (file)
@@ -161,6 +161,16 @@ endef
 $(eval $(call KernelPackage,ata-via-sata))
 
 
+define KernelPackage/block2mtd
+  SUBMENU:=$(BLOCK_MENU)
+  TITLE:=Block device MTD emulation
+  KCONFIG:=CONFIG_MTD_BLOCK2MTD
+  FILES:=$(LINUX_DIR)/drivers/mtd/devices/block2mtd.$(LINUX_KMOD_SUFFIX)
+endef
+
+$(eval $(call KernelPackage,block2mtd))
+
+
 define KernelPackage/dm
   SUBMENU:=$(BLOCK_MENU)
   TITLE:=Device Mapper
index 177318d4822d3a9a2107c9f553bb3f83bf9ff638..10db180e5f1f023c3fa94a5c1a436e6cb47d43e9 100644 (file)
@@ -7,14 +7,6 @@
 
 OTHER_MENU:=Other modules
 
-define KernelPackage/block2mtd
-  SUBMENU:=$(OTHER_MENU)
-  TITLE:=Block device MTD emulation
-  KCONFIG:=CONFIG_MTD_BLOCK2MTD
-  FILES:=$(LINUX_DIR)/drivers/mtd/devices/block2mtd.$(LINUX_KMOD_SUFFIX)
-endef
-$(eval $(call KernelPackage,block2mtd))
-
 define KernelPackage/crc-itu-t
   SUBMENU:=$(OTHER_MENU)
   TITLE:=CRC ITU-T V.41 support