kernel: bump 5.10 to 5.10.62
authorRui Salvaterra <rsalvaterra@gmail.com>
Fri, 3 Sep 2021 09:54:20 +0000 (10:54 +0100)
committerHauke Mehrtens <hauke@hauke-m.de>
Thu, 9 Sep 2021 21:40:32 +0000 (23:40 +0200)
Patches automatically refreshed.

Signed-off-by: Rui Salvaterra <rsalvaterra@gmail.com>
include/kernel-version.mk
target/linux/ath79/patches-5.10/910-unaligned_access_hacks.patch
target/linux/bcm27xx/patches-5.10/950-0409-drm-atomic-Pass-the-full-state-to-CRTC-atomic_check.patch
target/linux/bcm27xx/patches-5.10/950-0689-drm-automatic-legacy-gamma-support.patch
target/linux/generic/backport-5.10/781-v5.13-net-dsa-mt7530-Add-support-for-EEE-features.patch
target/linux/generic/pending-5.10/670-ipv6-allow-rejecting-with-source-address-failed-policy.patch

index 601058ef6ad46b200050fe3071e7fce349476cf2..70d307c5a47d48e63d6ede64a000c6eb7f77be1b 100644 (file)
@@ -7,10 +7,10 @@ ifdef CONFIG_TESTING_KERNEL
 endif
 
 LINUX_VERSION-5.4 = .143
-LINUX_VERSION-5.10 = .61
+LINUX_VERSION-5.10 = .62
 
 LINUX_KERNEL_HASH-5.4.143 = 0953650b05a5f806d76c5691583e94e141f4f691bc0ba75a60b643740f021d24
-LINUX_KERNEL_HASH-5.10.61 = 82eae38cc5cd11dd6aaac91c02ff0d006c7bafd6d4cf5c6a791930820a3a91d1
+LINUX_KERNEL_HASH-5.10.62 = 098dd5024d14b01a5ce85a6fec3dd829f4ac62488e4c59004a4687f8bbf886b1
 
 remove_uri_prefix=$(subst git://,,$(subst http://,,$(subst https://,,$(1))))
 sanitize_uri=$(call qstrip,$(subst @,_,$(subst :,_,$(subst .,_,$(subst -,_,$(subst /,_,$(1)))))))
index e0bcb8d34ef78968ed26c3c6a6e33e8b6a9232de..338b96447db3092ae350322c951523879895d5c5 100644 (file)
  #define UDP_CORK      1       /* Never send partially complete segments */
 --- a/net/netfilter/nf_conntrack_core.c
 +++ b/net/netfilter/nf_conntrack_core.c
-@@ -273,8 +273,8 @@ nf_ct_get_tuple(const struct sk_buff *sk
+@@ -268,8 +268,8 @@ nf_ct_get_tuple(const struct sk_buff *sk
  
        switch (l3num) {
        case NFPROTO_IPV4:
index 5111cc280b595bf3b8be59b1a930e8b914d993cb..86481e8955c4e691b93dca092da6af0bb142e839 100644 (file)
@@ -672,7 +672,7 @@ Link: https://patchwork.freedesktop.org/patch/msgid/20201028123222.1732139-1-max
  #include <drm/drm_atomic_helper.h>
  #include <drm/drm_crtc_helper.h>
  #include <drm/drm_vblank.h>
-@@ -310,12 +311,14 @@ nv50_head_atomic_check_mode(struct nv50_
+@@ -315,12 +316,14 @@ nv50_head_atomic_check_mode(struct nv50_
  }
  
  static int
index c6f9bf19d3c996a51a7006e30d8bcc160e945ee1..b1cb34e485e31f4a3056f5515e52e72f6c6696cb 100644 (file)
@@ -367,7 +367,7 @@ Link: https://patchwork.freedesktop.org/patch/msgid/20201211114237.213288-2-tomi
  };
 --- a/drivers/gpu/drm/nouveau/dispnv50/head.c
 +++ b/drivers/gpu/drm/nouveau/dispnv50/head.c
-@@ -501,7 +501,6 @@ nv50_head_destroy(struct drm_crtc *crtc)
+@@ -506,7 +506,6 @@ nv50_head_destroy(struct drm_crtc *crtc)
  static const struct drm_crtc_funcs
  nv50_head_func = {
        .reset = nv50_head_reset,
@@ -375,7 +375,7 @@ Link: https://patchwork.freedesktop.org/patch/msgid/20201211114237.213288-2-tomi
        .destroy = nv50_head_destroy,
        .set_config = drm_atomic_helper_set_config,
        .page_flip = drm_atomic_helper_page_flip,
-@@ -516,7 +515,6 @@ nv50_head_func = {
+@@ -521,7 +520,6 @@ nv50_head_func = {
  static const struct drm_crtc_funcs
  nvd9_head_func = {
        .reset = nv50_head_reset,
index bba31366924c7b6a1b2d138fd46ddf9f2e422fa2..ae4270391d526eade179120c2abb04229b7cd086 100644 (file)
@@ -17,7 +17,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
 
 --- a/drivers/net/dsa/mt7530.c
 +++ b/drivers/net/dsa/mt7530.c
-@@ -2270,6 +2270,17 @@ static void mt753x_phylink_mac_link_up(s
+@@ -2267,6 +2267,17 @@ static void mt753x_phylink_mac_link_up(s
                        mcr |= PMCR_RX_FC_EN;
        }
  
@@ -35,7 +35,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
        mt7530_set(priv, MT7530_PMCR_P(port), mcr);
  }
  
-@@ -2500,6 +2511,36 @@ mt753x_phy_write(struct dsa_switch *ds,
+@@ -2497,6 +2508,36 @@ mt753x_phy_write(struct dsa_switch *ds,
        return priv->info->phy_write(ds, port, regnum, val);
  }
  
@@ -72,7 +72,7 @@ Signed-off-by: David S. Miller <davem@davemloft.net>
  static const struct dsa_switch_ops mt7530_switch_ops = {
        .get_tag_protocol       = mtk_get_tag_protocol,
        .setup                  = mt753x_setup,
-@@ -2528,6 +2569,8 @@ static const struct dsa_switch_ops mt753
+@@ -2525,6 +2566,8 @@ static const struct dsa_switch_ops mt753
        .phylink_mac_an_restart = mt753x_phylink_mac_an_restart,
        .phylink_mac_link_down  = mt753x_phylink_mac_link_down,
        .phylink_mac_link_up    = mt753x_phylink_mac_link_up,
index 6fe3b327c50a93388e008e4a2e5743c83f9670c6..4abdce85d017127cda9874f12cb321e1e20288d3 100644 (file)
@@ -110,7 +110,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                return -EINVAL;
 --- a/net/ipv6/route.c
 +++ b/net/ipv6/route.c
-@@ -94,6 +94,8 @@ static int           ip6_pkt_discard(struct sk_bu
+@@ -95,6 +95,8 @@ static int           ip6_pkt_discard(struct sk_bu
  static int            ip6_pkt_discard_out(struct net *net, struct sock *sk, struct sk_buff *skb);
  static int            ip6_pkt_prohibit(struct sk_buff *skb);
  static int            ip6_pkt_prohibit_out(struct net *net, struct sock *sk, struct sk_buff *skb);
@@ -119,7 +119,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  static void           ip6_link_failure(struct sk_buff *skb);
  static void           ip6_rt_update_pmtu(struct dst_entry *dst, struct sock *sk,
                                           struct sk_buff *skb, u32 mtu,
-@@ -309,6 +311,18 @@ static const struct rt6_info ip6_prohibi
+@@ -310,6 +312,18 @@ static const struct rt6_info ip6_prohibi
        .rt6i_flags     = (RTF_REJECT | RTF_NONEXTHOP),
  };
  
@@ -138,7 +138,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  static const struct rt6_info ip6_blk_hole_entry_template = {
        .dst = {
                .__refcnt       = ATOMIC_INIT(1),
-@@ -1030,6 +1044,7 @@ static const int fib6_prop[RTN_MAX + 1]
+@@ -1031,6 +1045,7 @@ static const int fib6_prop[RTN_MAX + 1]
        [RTN_BLACKHOLE] = -EINVAL,
        [RTN_UNREACHABLE] = -EHOSTUNREACH,
        [RTN_PROHIBIT]  = -EACCES,
@@ -146,7 +146,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
        [RTN_THROW]     = -EAGAIN,
        [RTN_NAT]       = -EINVAL,
        [RTN_XRESOLVE]  = -EINVAL,
-@@ -1065,6 +1080,10 @@ static void ip6_rt_init_dst_reject(struc
+@@ -1066,6 +1081,10 @@ static void ip6_rt_init_dst_reject(struc
                rt->dst.output = ip6_pkt_prohibit_out;
                rt->dst.input = ip6_pkt_prohibit;
                break;
@@ -157,7 +157,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
        case RTN_THROW:
        case RTN_UNREACHABLE:
        default:
-@@ -4418,6 +4437,17 @@ static int ip6_pkt_prohibit_out(struct n
+@@ -4426,6 +4445,17 @@ static int ip6_pkt_prohibit_out(struct n
        return ip6_pkt_drop(skb, ICMPV6_ADM_PROHIBITED, IPSTATS_MIB_OUTNOROUTES);
  }
  
@@ -175,7 +175,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  /*
   *    Allocate a dst for local (unicast / anycast) address.
   */
-@@ -4898,7 +4928,8 @@ static int rtm_to_fib6_config(struct sk_
+@@ -4906,7 +4936,8 @@ static int rtm_to_fib6_config(struct sk_
        if (rtm->rtm_type == RTN_UNREACHABLE ||
            rtm->rtm_type == RTN_BLACKHOLE ||
            rtm->rtm_type == RTN_PROHIBIT ||
@@ -185,7 +185,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                cfg->fc_flags |= RTF_REJECT;
  
        if (rtm->rtm_type == RTN_LOCAL)
-@@ -6068,6 +6099,8 @@ static int ip6_route_dev_notify(struct n
+@@ -6076,6 +6107,8 @@ static int ip6_route_dev_notify(struct n
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
                net->ipv6.ip6_prohibit_entry->dst.dev = dev;
                net->ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(dev);
@@ -194,7 +194,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                net->ipv6.ip6_blk_hole_entry->dst.dev = dev;
                net->ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(dev);
  #endif
-@@ -6079,6 +6112,7 @@ static int ip6_route_dev_notify(struct n
+@@ -6087,6 +6120,7 @@ static int ip6_route_dev_notify(struct n
                in6_dev_put_clear(&net->ipv6.ip6_null_entry->rt6i_idev);
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
                in6_dev_put_clear(&net->ipv6.ip6_prohibit_entry->rt6i_idev);
@@ -202,7 +202,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
                in6_dev_put_clear(&net->ipv6.ip6_blk_hole_entry->rt6i_idev);
  #endif
        }
-@@ -6270,6 +6304,8 @@ static int __net_init ip6_route_net_init
+@@ -6278,6 +6312,8 @@ static int __net_init ip6_route_net_init
  
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        net->ipv6.fib6_has_custom_rules = false;
@@ -211,7 +211,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
        net->ipv6.ip6_prohibit_entry = kmemdup(&ip6_prohibit_entry_template,
                                               sizeof(*net->ipv6.ip6_prohibit_entry),
                                               GFP_KERNEL);
-@@ -6280,11 +6316,21 @@ static int __net_init ip6_route_net_init
+@@ -6288,11 +6324,21 @@ static int __net_init ip6_route_net_init
                         ip6_template_metrics, true);
        INIT_LIST_HEAD(&net->ipv6.ip6_prohibit_entry->rt6i_uncached);
  
@@ -234,7 +234,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
        net->ipv6.ip6_blk_hole_entry->dst.ops = &net->ipv6.ip6_dst_ops;
        dst_init_metrics(&net->ipv6.ip6_blk_hole_entry->dst,
                         ip6_template_metrics, true);
-@@ -6311,6 +6357,8 @@ out:
+@@ -6319,6 +6365,8 @@ out:
        return ret;
  
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
@@ -243,7 +243,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
  out_ip6_prohibit_entry:
        kfree(net->ipv6.ip6_prohibit_entry);
  out_ip6_null_entry:
-@@ -6330,6 +6378,7 @@ static void __net_exit ip6_route_net_exi
+@@ -6338,6 +6386,7 @@ static void __net_exit ip6_route_net_exi
        kfree(net->ipv6.ip6_null_entry);
  #ifdef CONFIG_IPV6_MULTIPLE_TABLES
        kfree(net->ipv6.ip6_prohibit_entry);
@@ -251,7 +251,7 @@ Signed-off-by: Jonas Gorski <jogo@openwrt.org>
        kfree(net->ipv6.ip6_blk_hole_entry);
  #endif
        dst_entries_destroy(&net->ipv6.ip6_dst_ops);
-@@ -6407,6 +6456,9 @@ void __init ip6_route_init_special_entri
+@@ -6415,6 +6464,9 @@ void __init ip6_route_init_special_entri
        init_net.ipv6.ip6_prohibit_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);
        init_net.ipv6.ip6_blk_hole_entry->dst.dev = init_net.loopback_dev;
        init_net.ipv6.ip6_blk_hole_entry->rt6i_idev = in6_dev_get(init_net.loopback_dev);