dante: fix broken configure script not using CFLAGS for conftest
authorFlorian Fainelli <florian@openwrt.org>
Tue, 19 Feb 2013 17:22:55 +0000 (17:22 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Tue, 19 Feb 2013 17:22:55 +0000 (17:22 +0000)
Spotted by doing an ARM hard float build.

Signed-off-by: Florian Fainelli <florian@openwrt.org>
SVN-Revision: 35685

package/network/utils/dante/Makefile

index 90768ad474640faa826802223b536fefa1b9e3c1..cdd472b9ee6bf421f8c038f45610fb7ed1a3c8d8 100644 (file)
@@ -28,6 +28,9 @@ CONFIGURE_ARGS += \
        --without-pam \
        --disable-libwrap
 
+CONFIGURE_VARS += \
+       CC="$(TARGET_CC) $(TARGET_CFLAGS)"
+
 define Build/InstallDev
        $(INSTALL_DIR) $(1)/usr/include
        $(CP) $(PKG_INSTALL_DIR)/usr/include/* $(1)/usr/include/