kernel: update 3.18 to 3.18.19
authorJonas Gorski <jogo@openwrt.org>
Wed, 22 Jul 2015 12:50:59 +0000 (12:50 +0000)
committerJonas Gorski <jogo@openwrt.org>
Wed, 22 Jul 2015 12:50:59 +0000 (12:50 +0000)
Changelog:
 * https://www.kernel.org/pub/linux/kernel/v3.x/ChangeLog-3.18.19

Signed-off-by: Jonas Gorski <jogo@openwrt.org>
SVN-Revision: 46439

include/kernel-version.mk
target/linux/ar71xx/patches-3.18/707-MIPS-ath79-add-support-for-QCA953x-SoC.patch
target/linux/ar71xx/patches-3.18/718-MIPS-ath79-add-EPG5000-support.patch
target/linux/ar71xx/patches-3.18/735-MIPS-ath79-add-support-for-QCA956x-SoC.patch
target/linux/ar71xx/patches-3.18/736-MIPS-ath79-add-MC-MAC1200R-support.patch
target/linux/ar71xx/patches-3.18/737-MIPS-ath79-add-om5p-an-support.patch
target/linux/ar71xx/patches-3.18/738-MIPS-ath79-add-meraki-mr12-mr16-support.patch
target/linux/ar71xx/patches-3.18/800-MIPS-ath79-add-RB922GS-support.patch
target/linux/ar71xx/patches-3.18/811-MIPS-ath79-gpio-enable-set-direction.patch
target/linux/ar71xx/patches-3.18/903-MIPS-ath79-ubnt-rocket-m-xw-support.patch
target/linux/ar71xx/patches-3.18/904-MIPS-ath79-ubnt-rocket-m-ti-supprt.patch

index e0b98267c69ed781787243070ddcd82d8906e947..0a4243e8d0809ecf7e01d439711eb1a57037a174 100644 (file)
@@ -2,11 +2,11 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-3.18 = .18
+LINUX_VERSION-3.18 = .19
 LINUX_VERSION-4.0 = .8
 LINUX_VERSION-4.1 = .3
 
-LINUX_KERNEL_MD5SUM-3.18.18 = 6fce868a56f2d83f80cdad5fed457110
+LINUX_KERNEL_MD5SUM-3.18.19 = a143f9421bd8413752609d0d771c2955
 LINUX_KERNEL_MD5SUM-4.0.8 = a99375dd855de00635e9ac8e62b0f8e6
 LINUX_KERNEL_MD5SUM-4.1.3 = 96c2c77b1c54ba01cfd8fc2d13fbf828
 
index f8b12641558b66035ad2b48deb2062f3f87eea61..1fe0e34ca9be0b28217a6f6a745671e6775606e4 100644 (file)
@@ -22,7 +22,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
 
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -1205,6 +1205,10 @@ config SOC_AR934X
+@@ -1229,6 +1229,10 @@ config SOC_AR934X
        select PCI_AR724X if PCI
        def_bool n
  
@@ -33,7 +33,7 @@ meaning of the bits CPUCLK_FROM_CPUPLL and DDRCLK_FROM_DDRPLL is reversed.
  config SOC_QCA955X
        select HW_HAS_PCI
        select PCI_AR724X if PCI
-@@ -1247,7 +1251,7 @@ config ATH79_DEV_USB
+@@ -1271,7 +1275,7 @@ config ATH79_DEV_USB
        def_bool n
  
  config ATH79_DEV_WMAC
index 1ae0e2d76be234d7652a7fae5c9e2421ad78e558..a47e24d61b958a736397e564859ff7ac8028ec90 100644 (file)
@@ -20,7 +20,7 @@
        select SOC_QCA955X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -70,6 +70,7 @@ obj-$(CONFIG_ATH79_MACH_EAP300V2)    += mac
+@@ -72,6 +72,7 @@ obj-$(CONFIG_ATH79_MACH_EAP300V2)    += mac
  obj-$(CONFIG_ATH79_MACH_EAP7660D)     += mach-eap7660d.o
  obj-$(CONFIG_ATH79_MACH_EL_M150)      += mach-el-m150.o
  obj-$(CONFIG_ATH79_MACH_EL_MINI)      += mach-el-mini.o
@@ -30,7 +30,7 @@
  obj-$(CONFIG_ATH79_MACH_GL_INET)      += mach-gl-inet.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -60,6 +60,7 @@ enum ath79_mach_type {
+@@ -62,6 +62,7 @@ enum ath79_mach_type {
        ATH79_MACH_EL_M150,             /* EasyLink EL-M150 */
        ATH79_MACH_EL_MINI,             /* EasyLink EL-MINI */
        ATH79_MACH_ESR1750,             /* EnGenius ESR1750 */
index e980964fd6a5a95d09b60fba8190ff19e7fb431e..3b8e6c55fa3ee23081e6aa5b666169d9e069e0c4 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -1225,6 +1225,12 @@ config SOC_QCA955X
+@@ -1249,6 +1249,12 @@ config SOC_QCA955X
        select PCI_AR724X if PCI
        def_bool n
  
@@ -13,7 +13,7 @@
  config ATH79_DEV_M25P80
        select ATH79_DEV_SPI
        def_bool n
-@@ -1262,7 +1268,7 @@ config ATH79_DEV_USB
+@@ -1286,7 +1292,7 @@ config ATH79_DEV_USB
        def_bool n
  
  config ATH79_DEV_WMAC
index cfdf1209c638a41a477cd365e3b69ac036fa6e8c..4c041d0b53f978c6bbf91f07a7243aecd0ac401f 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -566,6 +566,16 @@ config ATH79_MACH_R6100
+@@ -590,6 +590,16 @@ config ATH79_MACH_R6100
        select ATH79_DEV_USB
        select ATH79_DEV_WMAC
  
@@ -19,7 +19,7 @@
        select SOC_AR71XX
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -79,6 +79,7 @@ obj-$(CONFIG_ATH79_MACH_HIWIFI_HC6361)       +
+@@ -81,6 +81,7 @@ obj-$(CONFIG_ATH79_MACH_HIWIFI_HC6361)       +
  obj-$(CONFIG_ATH79_MACH_JA76PF)               += mach-ja76pf.o
  obj-$(CONFIG_ATH79_MACH_JWAP003)      += mach-jwap003.o
  obj-$(CONFIG_ATH79_MACH_HORNET_UB)    += mach-hornet-ub.o
@@ -29,7 +29,7 @@
  obj-$(CONFIG_ATH79_MACH_MYNET_N600)   += mach-mynet-n600.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -118,6 +118,7 @@ enum ath79_mach_type {
+@@ -120,6 +120,7 @@ enum ath79_mach_type {
        ATH79_MACH_TEW_673GRU,          /* TRENDnet TEW-673GRU */
        ATH79_MACH_TEW_712BR,           /* TRENDnet TEW-712BR */
        ATH79_MACH_TEW_732BR,           /* TRENDnet TEW-732BR */
index c3097bcd0a4df4037afd9a4e17c5d0c422f988e1..935a845ab44a27f0b288efcf46617094aa38d1d5 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -85,6 +85,7 @@ enum ath79_mach_type {
+@@ -87,6 +87,7 @@ enum ath79_mach_type {
        ATH79_MACH_OM2P_LC,             /* OpenMesh OM2P-LC */
        ATH79_MACH_OM2Pv2,              /* OpenMesh OM2Pv2 */
        ATH79_MACH_OM2P,                /* OpenMesh OM2P */
@@ -10,7 +10,7 @@
        ATH79_MACH_PB92,                /* Atheros PB92 */
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -719,6 +719,7 @@ config ATH79_MACH_OM2P
+@@ -743,6 +743,7 @@ config ATH79_MACH_OM2P
  config ATH79_MACH_OM5P
        bool "OpenMesh OM5P board support"
        select SOC_AR934X
index 3bbad4ac0ae0f524cfb5f4f531ea099c71c5d0f7..94d0aedc56a8677d72ec6f1d7f129f9cf6ed6707 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -726,6 +726,26 @@ config ATH79_MACH_OM5P
+@@ -750,6 +750,26 @@ config ATH79_MACH_OM5P
        select ATH79_DEV_M25P80
        select ATH79_DEV_WMAC
  
@@ -29,7 +29,7 @@
        select SOC_AR934X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -80,6 +80,8 @@ obj-$(CONFIG_ATH79_MACH_JA76PF)              += mach
+@@ -82,6 +82,8 @@ obj-$(CONFIG_ATH79_MACH_JA76PF)              += mach
  obj-$(CONFIG_ATH79_MACH_JWAP003)      += mach-jwap003.o
  obj-$(CONFIG_ATH79_MACH_HORNET_UB)    += mach-hornet-ub.o
  obj-$(CONFIG_ATH79_MACH_MC_MAC1200R)     += mach-mc-mac1200r.o
@@ -40,7 +40,7 @@
  obj-$(CONFIG_ATH79_MACH_MYNET_N600)   += mach-mynet-n600.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -69,6 +69,8 @@ enum ath79_mach_type {
+@@ -71,6 +71,8 @@ enum ath79_mach_type {
        ATH79_MACH_JA76PF2,             /* jjPlus JA76PF2 */
        ATH79_MACH_JWAP003,             /* jjPlus JWAP003 */
        ATH79_MACH_HORNET_UB,           /* ALFA Networks Hornet-UB */
index bf316d65a17509dc2163cc3e77beac59e8034278..baa8cb820452355a7df555c1f7735ffd50643cb7 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/Kconfig
 +++ b/arch/mips/ath79/Kconfig
-@@ -601,6 +601,16 @@ config ATH79_MACH_RB91X
+@@ -625,6 +625,16 @@ config ATH79_MACH_RB91X
        select ATH79_DEV_USB
        select ATH79_ROUTERBOOT
  
@@ -19,7 +19,7 @@
         select SOC_AR934X
 --- a/arch/mips/ath79/Makefile
 +++ b/arch/mips/ath79/Makefile
-@@ -100,6 +100,7 @@ obj-$(CONFIG_ATH79_MACH_R6100)             += mach-
+@@ -102,6 +102,7 @@ obj-$(CONFIG_ATH79_MACH_R6100)             += mach-
  obj-$(CONFIG_ATH79_MACH_RB4XX)                += mach-rb4xx.o
  obj-$(CONFIG_ATH79_MACH_RB750)                += mach-rb750.o
  obj-$(CONFIG_ATH79_MACH_RB91X)                += mach-rb91x.o
@@ -29,7 +29,7 @@
  obj-$(CONFIG_ATH79_MACH_RBSXTLITE)    += mach-rbsxtlite.o
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -107,6 +107,7 @@ enum ath79_mach_type {
+@@ -109,6 +109,7 @@ enum ath79_mach_type {
        ATH79_MACH_RB_750G_R3,          /* MikroTik RouterBOARD 750GL */
        ATH79_MACH_RB_751,              /* MikroTik RouterBOARD 751 */
        ATH79_MACH_RB_751G,             /* Mikrotik RouterBOARD 751G */
index c628f1df8916db9df35fb0f20afc15fdaea0cf21..b5dbb74d79d7a27803fbb3380a521f758787d5b2 100644 (file)
@@ -10,7 +10,7 @@
  #endif /* __ATH79_COMMON_H */
 --- a/arch/mips/ath79/gpio.c
 +++ b/arch/mips/ath79/gpio.c
-@@ -130,6 +130,30 @@ static int ar934x_gpio_direction_output(
+@@ -142,6 +142,30 @@ static int ar934x_gpio_direction_output(
        return 0;
  }
  
index 7fdefd65d56f181b299dd3c0f30fa82b463ce099..ad302636da3ead34ed4455711b2c5bac57cb9bcf 100644 (file)
@@ -1,6 +1,6 @@
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -174,6 +174,7 @@ enum ath79_mach_type {
+@@ -176,6 +176,7 @@ enum ath79_mach_type {
        ATH79_MACH_UBNT_NANO_M,         /* Ubiquiti NanoStation M */
        ATH79_MACH_UBNT_NANO_M_XW,      /* Ubiquiti NanoStation M XW */
        ATH79_MACH_UBNT_ROCKET_M,       /* Ubiquiti Rocket M */
index 74958921e6186867afb2fc15d946b767821aa5df..52d4a09bcca347b43b9620c0f7e7c10970ae9e1e 100644 (file)
                .name      = "ubnt:blue:wlan",
 --- a/arch/mips/ath79/machtypes.h
 +++ b/arch/mips/ath79/machtypes.h
-@@ -176,6 +176,7 @@ enum ath79_mach_type {
+@@ -178,6 +178,7 @@ enum ath79_mach_type {
        ATH79_MACH_UBNT_NANO_M_XW,      /* Ubiquiti NanoStation M XW */
        ATH79_MACH_UBNT_ROCKET_M,       /* Ubiquiti Rocket M */
        ATH79_MACH_UBNT_ROCKET_M_XW,    /* Ubiquiti Rocket M XW*/