libnftnl: Add nftables libnftnl
authorSteven Barth <cyrus@openwrt.org>
Wed, 17 Sep 2014 12:10:57 +0000 (12:10 +0000)
committerSteven Barth <cyrus@openwrt.org>
Wed, 17 Sep 2014 12:10:57 +0000 (12:10 +0000)
Signed-off-by: Steven Barth <steven@midlink.org>
SVN-Revision: 42597

package/libs/libnftnl/Makefile [new file with mode: 0644]

diff --git a/package/libs/libnftnl/Makefile b/package/libs/libnftnl/Makefile
new file mode 100644 (file)
index 0000000..5b3ad2e
--- /dev/null
@@ -0,0 +1,72 @@
+#
+# Copyright (C) 2014 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+include $(TOPDIR)/rules.mk
+
+PKG_NAME:=libnftnl
+PKG_VERSION:=1.0.2+2014-09-11
+PKG_RELEASE:=1
+
+PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.bz2
+PKG_SOURCE_SUBDIR:=$(PKG_NAME)-$(PKG_VERSION)
+PKG_SOURCE_URL:=git://git.netfilter.org/libnftnl
+PKG_SOURCE_PROTO:=git
+PKG_SOURCE_VERSION:=9c3cacb743d789bcac0f9ac8f40190741b9ae8eb
+PKG_MAINTAINER:=Steven Barth <steven@midlink.org>
+
+PKG_FIXUP:=autoreconf
+
+PKG_INSTALL:=1
+
+include $(INCLUDE_DIR)/package.mk
+
+define Package/libnftnl
+  SECTION:=libs
+  CATEGORY:=Libraries
+  DEPENDS:=+libmnl
+  TITLE:=Low-level netlink library for the nf_tables subsystem
+  URL:=http://www.netfilter.org/projects/libnftnl
+endef
+
+define Package/libnftnl/description
+ libnftnl is a userspace library providing a low-level netlink
+ programming interface (API) to the in-kernel nf_tables subsystem.
+endef
+
+TARGET_CFLAGS += $(FPIC)
+
+CONFIGURE_ARGS += \
+       --enable-static \
+       --enable-shared \
+       --without-json-parsing \
+       --without-xml-parsing \
+
+define Build/InstallDev
+       $(INSTALL_DIR) $(1)/usr/include/libnftnl
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/include/libnftnl/*.h \
+               $(1)/usr/include/libnftnl/
+
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libnftnl.{so*,a,la} \
+               $(1)/usr/lib/
+
+       $(INSTALL_DIR) $(1)/usr/lib/pkgconfig
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/pkgconfig/libnftnl.pc \
+               $(1)/usr/lib/pkgconfig/
+endef
+
+define Package/libnftnl/install
+       $(INSTALL_DIR) $(1)/usr/lib
+       $(CP) \
+               $(PKG_INSTALL_DIR)/usr/lib/libnftnl.so.* \
+               $(1)/usr/lib/
+endef
+
+$(eval $(call BuildPackage,libnftnl))