mediatek: enable support for vfpv4 and neon
authorChristian Lamparter <chunkeey@googlemail.com>
Fri, 25 Nov 2016 19:57:25 +0000 (20:57 +0100)
committerJohn Crispin <john@phrozen.org>
Tue, 20 Dec 2016 08:35:36 +0000 (09:35 +0100)
While researching for the armvirt target, I looked at the
existing arm platforms. It turns out that the mediatek target
with its sole MT7623N/A chip is sold as a "highly integrated
multimedia network router system-on-chip". To that end, it
lists support for the "NEON multimedia processing engine with
SIMDv2 / VFPv4 ISA support".

<http://topics.mediatek.com/en/products/connectivity/wifi/home-network/wifi-ap/mt7623na/>

So this patch enables the CPU_SUBTYPE to use this information.
This should have the nice side effect that LEDE's phase2 builders
no longer need to built a separate "cortex-a7" target, so this
should free up some resources.

Cc: John Crispin <john@phrozen.org>
Signed-off-by: Christian Lamparter <chunkeey@gmail.com>
target/linux/mediatek/Makefile

index 689ba31b024a0945ffb9b9c493ffbf74057e8dd8..e3eecd5886c29fe90c5a5bbb5945cb1fcc481822 100644 (file)
@@ -7,6 +7,7 @@ BOARD:=mediatek
 BOARDNAME:=MediaTek Ralink ARM
 FEATURES:=squashfs nand ubifs
 CPU_TYPE:=cortex-a7
+CPU_SUBTYPE:=neon-vfpv4
 MAINTAINER:=John Crispin <john@phrozen.org>
 
 KERNEL_PATCHVER:=4.4