oxnas: use generic filenames for image and DTS
authorDaniel Golle <daniel@makrotopia.org>
Mon, 11 Mar 2019 02:40:44 +0000 (03:40 +0100)
committerDaniel Golle <daniel@makrotopia.org>
Mon, 11 Mar 2019 02:43:30 +0000 (03:43 +0100)
Signed-off-by: Daniel Golle <daniel@makrotopia.org>
target/linux/oxnas/files/arch/arm/boot/dts/ox820-cloudengines-pogoplug-pro.dts [deleted file]
target/linux/oxnas/files/arch/arm/boot/dts/ox820-cloudengines-pogoplugpro.dts [new file with mode: 0644]
target/linux/oxnas/files/arch/arm/boot/dts/ox820-mitrastar-stg-212.dts [new file with mode: 0644]
target/linux/oxnas/files/arch/arm/boot/dts/ox820-mitrastar-stg212.dts [deleted file]
target/linux/oxnas/image/ox820.mk
target/linux/oxnas/patches-4.14/040-pogoplug-series-3-compatible-string.patch [new file with mode: 0644]

diff --git a/target/linux/oxnas/files/arch/arm/boot/dts/ox820-cloudengines-pogoplug-pro.dts b/target/linux/oxnas/files/arch/arm/boot/dts/ox820-cloudengines-pogoplug-pro.dts
deleted file mode 100644 (file)
index a629c31..0000000
+++ /dev/null
@@ -1,122 +0,0 @@
-/*
- * cloudengines-pogoplug-series-3.dtsi - Device tree file for Cloud Engines PogoPlug Series 3
- *
- * Copyright (C) 2016 Neil Armstrong <narmstrong@baylibre.com>
- *
- * Licensed under GPLv2 or later
- */
-
-/dts-v1/;
-#include "ox820.dtsi"
-
-/ {
-       model = "Cloud Engines PogoPlug Pro";
-
-       compatible = "cloudengines,pogoplugpro", "oxsemi,ox820";
-
-       chosen {
-               bootargs = "earlyprintk console=ttyS0,115200";
-               stdout-path = "serial0:115200n8";
-       };
-
-       memory {
-               /* 128Mbytes DDR */
-               reg = <0x60000000 0x8000000>;
-       };
-
-       aliases {
-               serial0 = &uart0;
-               gpio0 = &gpio0;
-               gpio1 = &gpio1;
-               led-boot = &led_status;
-               led-failsafe = &led_warn;
-               led-running = &led_act;
-               led-upgrade = &led_warn;
-       };
-
-       leds {
-               compatible = "gpio-leds";
-
-               led_status: blue {
-                       label = "pogoplug:blue";
-                       gpios = <&gpio0 2 0>;
-                       default-state = "keep";
-               };
-
-               led_warn: orange {
-                       label = "pogoplug:orange";
-                       gpios = <&gpio1 16 1>;
-                       default-state = "keep";
-               };
-
-               led_act: green {
-                       label = "pogoplug:green";
-                       gpios = <&gpio1 17 1>;
-                       default-state = "keep";
-               };
-       };
-};
-
-&uart0 {
-       status = "okay";
-
-       pinctrl-names = "default";
-       pinctrl-0 = <&pinctrl_uart0>;
-};
-
-&nandc {
-       status = "okay";
-
-       pinctrl-names = "default";
-       pinctrl-0 = <&pinctrl_nand>;
-
-       nand@0 {
-               reg = <0>;
-               #address-cells = <1>;
-               #size-cells = <1>;
-               nand-ecc-mode = "soft";
-               nand-ecc-algo = "hamming";
-
-               partition@0 {
-                       label = "stage1";
-                       reg = <0x00000000 0x00040000>;
-                       read-only;
-               };
-
-               partition@40000 {
-                       label = "u-boot";
-                       reg = <0x00040000 0x00380000>;
-                       read-only;
-               };
-
-               partition@3c0000 {
-                       label = "u-boot-env";
-                       reg = <0x003c0000 0x00080000>;
-               };
-
-               partition@440000 {
-                       label = "kernel";
-                       reg = <0x00440000 0x009c0000>;
-               };
-
-               partition@e00000 {
-                       label = "ubi";
-                       reg = <0x00e00000 0x07200000>;
-               };
-       };
-};
-
-&ehci {
-       status = "okay";
-};
-
-&etha {
-       status = "okay";
-
-       pinctrl-names = "default";
-       pinctrl-0 = <&pinctrl_etha_mdio>;
-};
-
-&pcie0 {
-       status = "okay";
-};
diff --git a/target/linux/oxnas/files/arch/arm/boot/dts/ox820-cloudengines-pogoplugpro.dts b/target/linux/oxnas/files/arch/arm/boot/dts/ox820-cloudengines-pogoplugpro.dts
new file mode 100644 (file)
index 0000000..a629c31
--- /dev/null
@@ -0,0 +1,122 @@
+/*
+ * cloudengines-pogoplug-series-3.dtsi - Device tree file for Cloud Engines PogoPlug Series 3
+ *
+ * Copyright (C) 2016 Neil Armstrong <narmstrong@baylibre.com>
+ *
+ * Licensed under GPLv2 or later
+ */
+
+/dts-v1/;
+#include "ox820.dtsi"
+
+/ {
+       model = "Cloud Engines PogoPlug Pro";
+
+       compatible = "cloudengines,pogoplugpro", "oxsemi,ox820";
+
+       chosen {
+               bootargs = "earlyprintk console=ttyS0,115200";
+               stdout-path = "serial0:115200n8";
+       };
+
+       memory {
+               /* 128Mbytes DDR */
+               reg = <0x60000000 0x8000000>;
+       };
+
+       aliases {
+               serial0 = &uart0;
+               gpio0 = &gpio0;
+               gpio1 = &gpio1;
+               led-boot = &led_status;
+               led-failsafe = &led_warn;
+               led-running = &led_act;
+               led-upgrade = &led_warn;
+       };
+
+       leds {
+               compatible = "gpio-leds";
+
+               led_status: blue {
+                       label = "pogoplug:blue";
+                       gpios = <&gpio0 2 0>;
+                       default-state = "keep";
+               };
+
+               led_warn: orange {
+                       label = "pogoplug:orange";
+                       gpios = <&gpio1 16 1>;
+                       default-state = "keep";
+               };
+
+               led_act: green {
+                       label = "pogoplug:green";
+                       gpios = <&gpio1 17 1>;
+                       default-state = "keep";
+               };
+       };
+};
+
+&uart0 {
+       status = "okay";
+
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_uart0>;
+};
+
+&nandc {
+       status = "okay";
+
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_nand>;
+
+       nand@0 {
+               reg = <0>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+               nand-ecc-mode = "soft";
+               nand-ecc-algo = "hamming";
+
+               partition@0 {
+                       label = "stage1";
+                       reg = <0x00000000 0x00040000>;
+                       read-only;
+               };
+
+               partition@40000 {
+                       label = "u-boot";
+                       reg = <0x00040000 0x00380000>;
+                       read-only;
+               };
+
+               partition@3c0000 {
+                       label = "u-boot-env";
+                       reg = <0x003c0000 0x00080000>;
+               };
+
+               partition@440000 {
+                       label = "kernel";
+                       reg = <0x00440000 0x009c0000>;
+               };
+
+               partition@e00000 {
+                       label = "ubi";
+                       reg = <0x00e00000 0x07200000>;
+               };
+       };
+};
+
+&ehci {
+       status = "okay";
+};
+
+&etha {
+       status = "okay";
+
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_etha_mdio>;
+};
+
+&pcie0 {
+       status = "okay";
+};
diff --git a/target/linux/oxnas/files/arch/arm/boot/dts/ox820-mitrastar-stg-212.dts b/target/linux/oxnas/files/arch/arm/boot/dts/ox820-mitrastar-stg-212.dts
new file mode 100644 (file)
index 0000000..4610aab
--- /dev/null
@@ -0,0 +1,137 @@
+/dts-v1/;
+
+#include "ox820.dtsi"
+
+#include <dt-bindings/input/input.h>
+
+/ {
+       model = "MitraStar Technology Corp. STG-212";
+
+       compatible = "mitrastar,stg-212", "oxsemi,ox820";
+
+       chosen {
+               bootargs = "earlyprintk console=ttyS0,115200";
+               stdout-path = "serial0:115200n8";
+       };
+
+       memory {
+               /* 128Mbytes DDR */
+               reg = <0x60000000 0x8000000>;
+       };
+
+       aliases {
+               serial0 = &uart0;
+               gpio0 = &gpio0;
+               gpio1 = &gpio1;
+               led-boot = &led_status;
+               led-failsafe = &led_warn;
+               led-running = &led_status;
+               led-upgrade = &led_warn;
+       };
+
+       keys {
+               compatible = "gpio-keys-polled";
+               #address-cells = <1>;
+               #size-cells = <0>;
+               poll-interval = <100>;
+
+               reset {
+                       label = "reset";
+                       gpios = <&gpio1 11 1>;
+                       linux,code = <KEY_RESTART>;
+               };
+               copy {
+                       label = "copy";
+                       gpios = <&gpio1 13 1>;
+                       linux,code = <KEY_COPY>;
+               };
+       };
+
+       leds {
+               compatible = "gpio-leds";
+               led_status: status {
+                       label = "zyxel:blue:status";
+                       gpios = <&gpio1 5 0>;
+               };
+               led_warn: status2 {
+                       label = "zyxel:red:status";
+                       gpios = <&gpio1 6 1>;
+               };
+               copy {
+                       label = "zyxel:orange:copy";
+                       gpios = <&gpio1 8 1>;
+                       trigger-sources = <&ehci_port1>, <&ehci_port2>;
+                       linux,default-trigger = "usbport";
+               };
+       };
+
+       i2c-gpio {
+               compatible = "i2c-gpio";
+               gpios = <&gpio1 9 0 &gpio1 10 0>;
+               i2c-gpio,delay-us = <10>;
+       };
+};
+
+&uart0 {
+       status = "okay";
+
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_uart0>;
+};
+
+&nandc {
+       status = "okay";
+
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_nand>;
+
+       nand@0 {
+               reg = <0>;
+               #address-cells = <1>;
+               #size-cells = <1>;
+               nand-ecc-mode = "soft";
+               nand-ecc-algo = "hamming";
+
+               partition@0 {
+                       label = "stage1";
+                       reg = <0x00000000 0x00040000>;
+                       read-only;
+               };
+
+               partition@40000 {
+                       label = "u-boot";
+                       reg = <0x00040000 0x00380000>;
+                       read-only;
+               };
+
+               partition@3c0000 {
+                       label = "u-boot-env";
+                       reg = <0x003c0000 0x00080000>;
+               };
+
+               partition@440000 {
+                       label = "kernel";
+                       reg = <0x00440000 0x009c0000>;
+               };
+
+               partition@e00000 {
+                       label = "ubi";
+                       reg = <0x00e00000 0x07200000>;
+               };
+       };
+};
+
+&etha {
+       status = "okay";
+
+       pinctrl-names = "default";
+       pinctrl-0 = <&pinctrl_etha_mdio>;
+};
+
+&ehci {
+       status = "okay";
+};
+
+&sata {
+       status = "okay";
+};
diff --git a/target/linux/oxnas/files/arch/arm/boot/dts/ox820-mitrastar-stg212.dts b/target/linux/oxnas/files/arch/arm/boot/dts/ox820-mitrastar-stg212.dts
deleted file mode 100644 (file)
index 4610aab..0000000
+++ /dev/null
@@ -1,137 +0,0 @@
-/dts-v1/;
-
-#include "ox820.dtsi"
-
-#include <dt-bindings/input/input.h>
-
-/ {
-       model = "MitraStar Technology Corp. STG-212";
-
-       compatible = "mitrastar,stg-212", "oxsemi,ox820";
-
-       chosen {
-               bootargs = "earlyprintk console=ttyS0,115200";
-               stdout-path = "serial0:115200n8";
-       };
-
-       memory {
-               /* 128Mbytes DDR */
-               reg = <0x60000000 0x8000000>;
-       };
-
-       aliases {
-               serial0 = &uart0;
-               gpio0 = &gpio0;
-               gpio1 = &gpio1;
-               led-boot = &led_status;
-               led-failsafe = &led_warn;
-               led-running = &led_status;
-               led-upgrade = &led_warn;
-       };
-
-       keys {
-               compatible = "gpio-keys-polled";
-               #address-cells = <1>;
-               #size-cells = <0>;
-               poll-interval = <100>;
-
-               reset {
-                       label = "reset";
-                       gpios = <&gpio1 11 1>;
-                       linux,code = <KEY_RESTART>;
-               };
-               copy {
-                       label = "copy";
-                       gpios = <&gpio1 13 1>;
-                       linux,code = <KEY_COPY>;
-               };
-       };
-
-       leds {
-               compatible = "gpio-leds";
-               led_status: status {
-                       label = "zyxel:blue:status";
-                       gpios = <&gpio1 5 0>;
-               };
-               led_warn: status2 {
-                       label = "zyxel:red:status";
-                       gpios = <&gpio1 6 1>;
-               };
-               copy {
-                       label = "zyxel:orange:copy";
-                       gpios = <&gpio1 8 1>;
-                       trigger-sources = <&ehci_port1>, <&ehci_port2>;
-                       linux,default-trigger = "usbport";
-               };
-       };
-
-       i2c-gpio {
-               compatible = "i2c-gpio";
-               gpios = <&gpio1 9 0 &gpio1 10 0>;
-               i2c-gpio,delay-us = <10>;
-       };
-};
-
-&uart0 {
-       status = "okay";
-
-       pinctrl-names = "default";
-       pinctrl-0 = <&pinctrl_uart0>;
-};
-
-&nandc {
-       status = "okay";
-
-       pinctrl-names = "default";
-       pinctrl-0 = <&pinctrl_nand>;
-
-       nand@0 {
-               reg = <0>;
-               #address-cells = <1>;
-               #size-cells = <1>;
-               nand-ecc-mode = "soft";
-               nand-ecc-algo = "hamming";
-
-               partition@0 {
-                       label = "stage1";
-                       reg = <0x00000000 0x00040000>;
-                       read-only;
-               };
-
-               partition@40000 {
-                       label = "u-boot";
-                       reg = <0x00040000 0x00380000>;
-                       read-only;
-               };
-
-               partition@3c0000 {
-                       label = "u-boot-env";
-                       reg = <0x003c0000 0x00080000>;
-               };
-
-               partition@440000 {
-                       label = "kernel";
-                       reg = <0x00440000 0x009c0000>;
-               };
-
-               partition@e00000 {
-                       label = "ubi";
-                       reg = <0x00e00000 0x07200000>;
-               };
-       };
-};
-
-&etha {
-       status = "okay";
-
-       pinctrl-names = "default";
-       pinctrl-0 = <&pinctrl_etha_mdio>;
-};
-
-&ehci {
-       status = "okay";
-};
-
-&sata {
-       status = "okay";
-};
index 7f81fd2f598a0a6e986eb08c785d5530fb4d0c85..b7526cd86e9d74acac53dd77cd21fb6f2c301dee 100644 (file)
@@ -11,6 +11,8 @@ define Device/Default
   SUBPAGESIZE := 512
   FILESYSTEMS := squashfs ubifs
   PROFILES = Default $$(DTS)
+  SUPPORTED_DEVICES := $(subst _,$(comma),$(1))
+  DEVICE_DTS := ox820-$(subst _,-,$(1))
   KERNEL := kernel-bin | append-dtb | uImage none
   IMAGES := ubinized.bin sysupgrade.tar
   IMAGE/ubinized.bin := append-ubi
@@ -36,35 +38,31 @@ define Build/encrypt-3des
        openssl enc -des3 -a -k $(1) -in $@ -out $@.new && mv $@.new $@
 endef
 
-define Device/akitio-mycloud
-  DEVICE_DTS := ox820-akitio-mycloud
+define Device/akitio_mycloud
   DEVICE_TITLE := Akition myCloud (mini) / SilverStone DC01
-  SUPPORTED_DEVICES := akitio,mycloud akitio
+  SUPPORTED_DEVICES += akitio
   DEVICE_PACKAGES := kmod-usb2-oxnas kmod-ata-oxnas-sata kmod-usb-ledtrig-usbport \
                      kmod-i2c-gpio kmod-rtc-ds1307
 endef
-TARGET_DEVICES += akitio-mycloud
+TARGET_DEVICES += akitio_mycloud
 
-define Device/cloudengines-pogoplug-pro
-  DEVICE_DTS := ox820-cloudengines-pogoplug-pro
+define Device/cloudengines_pogoplugpro
   DEVICE_TITLE := Cloud Engines PogoPlug Pro (with mPCIe)
-  SUPPORTED_DEVICES := cloudengines,pogoplugpro pogoplug-pro
+  SUPPORTED_DEVICES += pogoplug-pro
   DEVICE_PACKAGES := kmod-usb2-oxnas kmod-usb-ledtrig-usbport
 endef
-TARGET_DEVICES += cloudengines-pogoplug-pro
+TARGET_DEVICES += cloudengines_pogoplugpro
 
-define Device/cloudengines-pogoplug-series-3
-  DEVICE_DTS := ox820-cloudengines-pogoplug-series-3
+define Device/cloudengines_pogoplug-series-3
   DEVICE_TITLE := Cloud Engines PogoPlug Series V3 (without mPCIe)
-  SUPPORTED_DEVICES := cloudengines,pogoplugv3 pogoplug-v3
+  SUPPORTED_DEVICES += cloudengines,pogoplugv3 pogoplug-v3
   DEVICE_PACKAGES := kmod-usb2-oxnas kmod-usb-ledtrig-usbport
 endef
-TARGET_DEVICES += cloudengines-pogoplug-series-3
+TARGET_DEVICES += cloudengines_pogoplug-series-3
 
-define Device/shuttle-kd20
-  DEVICE_DTS := ox820-shuttle-kd20
+define Device/shuttle_kd20
   DEVICE_TITLE := Shuttle KD20
-  SUPPORTED_DEVICES := shuttle,kd20 kd20
+  SUPPORTED_DEVICES += kd20
   KERNEL := kernel-bin | append-dtb | uImage none
   KERNEL_INITRAMFS_PREFIX = $$(IMAGE_PREFIX)-factory
   KERNEL_INITRAMFS_SUFFIX := .tar.gz
@@ -74,14 +72,13 @@ define Device/shuttle-kd20
                      kmod-hwmon-core kmod-hwmon-gpiofan \
                      kmod-md-mod kmod-md-raid0 kmod-md-raid1 kmod-fs-ext4 kmod-fs-xfs
 endef
-TARGET_DEVICES += shuttle-kd20
+TARGET_DEVICES += shuttle_kd20
 
-define Device/mitrastar-stg212
-  DEVICE_DTS := ox820-mitrastar-stg212
+define Device/mitrastar_stg-212
   DEVICE_TITLE := MitraStar STG-212
-  SUPPORTED_DEVICES := mitrastar,stg-212 stg212
+  SUPPORTED_DEVICES += stg212
   KERNEL := kernel-bin | append-dtb | uImage none
   DEVICE_PACKAGES := kmod-usb2-oxnas kmod-ata-oxnas-sata kmod-fs-ext4 kmod-fs-xfs \
                      kmod-usb-ledtrig-usbport
 endef
-TARGET_DEVICES += mitrastar-stg212
+TARGET_DEVICES += mitrastar_stg-212
diff --git a/target/linux/oxnas/patches-4.14/040-pogoplug-series-3-compatible-string.patch b/target/linux/oxnas/patches-4.14/040-pogoplug-series-3-compatible-string.patch
new file mode 100644 (file)
index 0000000..f14afd4
--- /dev/null
@@ -0,0 +1,11 @@
+--- a/arch/arm/boot/dts/ox820-cloudengines-pogoplug-series-3.dts
++++ b/arch/arm/boot/dts/ox820-cloudengines-pogoplug-series-3.dts
+@@ -12,7 +12,7 @@
+ / {
+       model = "Cloud Engines PogoPlug Series 3";
+-      compatible = "cloudengines,pogoplugv3", "oxsemi,ox820";
++      compatible = "cloudengines,pogoplug-series-3", "cloudengines,pogoplugv3", "oxsemi,ox820";
+       chosen {
+               bootargs = "earlyprintk console=ttyS0,115200";