base-files: add support for the morse LED trigger
authorGabor Juhos <juhosg@openwrt.org>
Sun, 25 Nov 2012 17:20:49 +0000 (17:20 +0000)
committerGabor Juhos <juhosg@openwrt.org>
Sun, 25 Nov 2012 17:20:49 +0000 (17:20 +0000)
Write "delay" and "message" options to their respective files,
allowing Morse code message configuration through UCI.
The delay (dit length) defaults to 150ms (about 8 words per minute,
suitable for beginners).

Signed-off-by: Petr Viktorin <encukou@gmail.com>
Signed-off-by: Gabor Juhos <juhosg@openwrt.org>
SVN-Revision: 34380

package/base-files/Makefile
package/base-files/files/etc/init.d/led

index 972f96b0cbf5a385e7949c1c5b0cfb4b4e8e6f73..7a2e216e816611676e7a87f52b4b431f93f3f885 100644 (file)
@@ -11,7 +11,7 @@ include $(INCLUDE_DIR)/kernel.mk
 include $(INCLUDE_DIR)/version.mk
 
 PKG_NAME:=base-files
-PKG_RELEASE:=119
+PKG_RELEASE:=120
 
 PKG_FILE_DEPENDS:=$(PLATFORM_DIR)/ $(GENERIC_PLATFORM_DIR)/base-files/
 PKG_BUILD_DEPENDS:=opkg/host
index f3f3c3f8a7c99ac73f4e3368671f02f011970a03..729796bcc7b79fd35cc043b33e5c6265f4193d19 100755 (executable)
@@ -24,6 +24,8 @@ load_led() {
        config_get delayoff $1 delayoff
        config_get interval $1 interval "50"
        config_get port_state $1 port_state
+       config_get delay $1 delay "150"
+       config_get message $1 message ""
 
        if [ "$trigger" = "rssi" ]; then
                # handled by rssileds userspace process
@@ -66,6 +68,11 @@ load_led() {
                                echo $port_state > /sys/class/leds/${sysfs}/port_state
                        ;;
 
+               "morse")
+                       echo $message > /sys/class/leds/${sysfs}/message
+                       echo $delay > /sys/class/leds/${sysfs}/delay
+                       ;;
+
                switch[0-9]*)
                        local port_mask