mtd: external toolchains usually do not know about MTDREFRESH, so search in $(LINUX_D...
authorJo-Philipp Wich <jow@openwrt.org>
Wed, 18 Jan 2012 19:22:14 +0000 (19:22 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Wed, 18 Jan 2012 19:22:14 +0000 (19:22 +0000)
SVN-Revision: 29779

package/mtd/Makefile

index 49a760be23cb9fa942bb38f22650749e017d61e8..27338d783b243ada562f69dff1eef102d476313c 100644 (file)
@@ -35,7 +35,7 @@ endef
 target=$(firstword $(subst -, ,$(BOARD)))
 
 MAKE_FLAGS += TARGET="$(target)"
-TARGET_CFLAGS += -Dtarget_$(target)=1 -Wall
+TARGET_CFLAGS := -I$(LINUX_DIR)/include $(TARGET_CFLAGS) -Dtarget_$(target)=1 -Wall
 
 ifdef CONFIG_MTD_REDBOOT_PARTS
   MAKE_FLAGS += FIS_SUPPORT=1