geos: cleanup GPIO driver name In 3.1, the old drivers/char/ entry for the CS5535...
authorJo-Philipp Wich <jow@openwrt.org>
Thu, 2 Feb 2012 18:44:35 +0000 (18:44 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Thu, 2 Feb 2012 18:44:35 +0000 (18:44 +0000)
SVN-Revision: 29995

target/linux/x86/geos/target.mk

index c601c278978c27910add5968ad315b982b2fd9e2..5e69002bd057e7bd1daf1e2e7d91d6547a4d3949 100644 (file)
@@ -1,9 +1,9 @@
+LINUX_VERSION:=3.2.2
 BOARDNAME:=Traverse Geos
 FEATURES:=squashfs jffs2 ext4 pci usb gpio
-GEOS_GPIO = $(if $(findstring 2.6.32,$(LINUX_VERSION)),gpio-cs5535,gpio-cs5535-new)
 DEFAULT_PACKAGES += \
             kmod-crypto-hw-geode kmod-crypto-ocf \
-            kmod-$(GEOS_GPIO) kmod-gpio-nsc \
+            kmod-gpio-cs5535-new kmod-gpio-nsc \
             kmod-wdt-geode kmod-cs5535-clockevt kmod-cs5535-mfgpt \
             kmod-cs5536 \
             kmod-hwmon-core kmod-hwmon-lm90 \
@@ -30,6 +30,6 @@ define Target/Description
     Build firmware images for Traverse Geos board
 endef
 
-define KernelPackage/$(GEOS_GPIO)/install
-     sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-$(GEOS_GPIO)
+define KernelPackage/gpio-cs5535-new/install
+     sed -i -r -e 's/$$$$$$$$/ mask=$(CS5535_MASK)/' $(1)/etc/modules.d/??-gpio-cs5535-new
 endef