fill in the kernel version info for every target, move the kernel tarball md5sums...
authorFelix Fietkau <nbd@openwrt.org>
Thu, 28 Jun 2007 05:52:00 +0000 (05:52 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Thu, 28 Jun 2007 05:52:00 +0000 (05:52 +0000)
SVN-Revision: 7748

20 files changed:
include/kernel-version.mk
target/linux/adm5120-2.6/Makefile
target/linux/adm5120eb-2.6/Makefile
target/linux/amcc-2.6/Makefile
target/linux/ar7-2.6/Makefile
target/linux/at91-2.6/Makefile
target/linux/atheros-2.6/Makefile
target/linux/au1000-2.6/Makefile
target/linux/avr32-2.6/Makefile
target/linux/brcm47xx-2.6/Makefile
target/linux/brcm63xx-2.6/Makefile
target/linux/iop32x-2.6/Makefile
target/linux/ixp4xx-2.6/Makefile
target/linux/magicbox-2.6/Makefile
target/linux/pxa-2.6/Makefile
target/linux/rb532-2.6/Makefile
target/linux/rdc-2.6/Makefile
target/linux/sibyte-2.6/Makefile
target/linux/uml-2.6/Makefile
target/linux/x86-2.6/Makefile

index eaac886ebb19920b56167972af6bb5dd6d8fcb44..9a9f1c8bffe8d4ab4aab3ff610a6ff23ed39523c 100644 (file)
@@ -3,13 +3,24 @@
 ifeq ($(LINUX_VERSION),)
   ifeq ($(KERNEL),2.4)
     LINUX_VERSION:=2.4.34
-    LINUX_RELEASE:=1
-    LINUX_KERNEL_MD5SUM:=f59665540a7f3351ea416a0dad104b55
   else
     LINUX_VERSION:=2.6.21.5
-    LINUX_RELEASE:=1
-    LINUX_KERNEL_MD5SUM:=2e9a302b5d514b231640227d6a2ab7bf
   endif
 endif
+LINUX_RELEASE?=1
+
+ifeq ($(LINUX_VERSION),2.4.34)
+  LINUX_KERNEL_MD5SUM:=f59665540a7f3351ea416a0dad104b55
+endif
+ifeq ($(LINUX_VERSION),2.6.22-rc6)
+  LINUX_KERNEL_MD5SUM:=37adac36f3928f5e05dd2704c083620d
+endif
+ifeq ($(LINUX_VERSION),2.6.21.5)
+  LINUX_KERNEL_MD5SUM:=2e9a302b5d514b231640227d6a2ab7bf
+endif
+
+# disable the md5sum check for unknown kernel versions
+LINUX_KERNEL_MD5SUM?=x
+
 KERNEL:=2.$(word 2,$(subst ., ,$(strip $(LINUX_VERSION))))
 
index 1ac2093930423fa32bc41eca0d05891953d234f3..3eeef4a4e8ca01fd7cb0bdf74193a44f2b00a719 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=adm5120
 BOARDNAME:=ADM5120 (Little Endian)
 FEATURES:=squashfs jffs2 pci usb
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Build firmware images for Infineon/ADMtek ADM5120 based boards
        (e.g : RouterBoard RB1xx, Compex WP54G-WRT ...)
index b645d020cef756322e790409fc57c2a68e08dd18..9b5c299203bb3f8775662cd154806be9688d5038 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=adm5120eb
 BOARDNAME:=ADM5120 (Big Endian)
 FEATURES:=squashfs pci usb
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Build firmware images for Infineon/ADMTek ADM5120 based boards running in big-endian mode
        (e.g : ZyXEL Prestige 335WT ...)
index 58d739df10e45b66781e78524c4291518c8ef64b..4dd366caa9ac34685be7fd25397def5e4d1e48fe 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=amcc
 BOARDNAME:=AMCC Taishan
 FEATURES:=jffs2
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Build firmware images for the AMCC Taishan evaluation board
 endef
index 4b10d565f595c008939f9eae84cf210a5d57b310..e6056b2f93f41024a271273c89b58dbd81375af0 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=ar7
 BOARDNAME:=TI AR7
 FEATURES:=squashfs jffs2 atm
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Build firmware images for TI AR7 based routers
 endef
index 982a91139fcac8cd7cd5214f4e6a41a26eb84984..ccd6353c816ec370c26ef23c82af8fd13fc9032c 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=at91
 BOARDNAME:=AT91
 FEATURES:=squashfs
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
   Build fimware images for Figment Design Labs VersaLink board.
 endef
index 1700dec8c6d48b4901e4805bbb249b953e6d82eb..f7500849884e7c52c0243ce71a735f3dbaa964bb 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=atheros
 BOARDNAME:=Atheros
 FEATURES:=squashfs jffs2
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Build firmware images for Atheros SoC boards
 endef
index c90d59d72fa41fc8f29e4b7b12b4f5e4c190acbc..0b04a4f5a58b4cf3c2ef2db948595efe78e6360b 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=au1000
 BOARDNAME:=AMD Alchemy AU1x00
 FEATURES:=jffs2 usb pci
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Build firmware for AMD Alchemy 1500 boards
        (e.g. 4G-Systems Mesh/Access Cube ...)
index 2dcd76a9b47c8e36a19151ab00775cf8f319ee05..465d96c93dc7647d718f8906fd671531e5196b0b 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=avr32
 BOARDNAME:=Atmel AVR32
 FEATURES:=squashfs
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
   Build firmware images for ATNGW100 board
 endef
index 34c29cf9adcf4f3c560c0745433151e299e4c42d..5f07cf20caf3518c65c5da599a83aa1cae2b16ea 100644 (file)
@@ -11,8 +11,7 @@ BOARD:=brcm47xx
 BOARDNAME:=Broadcom BCM947xx/953xx
 FEATURES:=squashfs usb
 
-LINUX_VERSION:=2.6.22-rc5
-LINUX_KERNEL_MD5SUM:=50dda556ae492f68ff7c273e1f357c55
+LINUX_VERSION:=2.6.22-rc6
 
 define Target/Description
        Build firmware images for Broadcom based routers
index 81a40d93e6a878e3c00b9b0fc7852a1d999f14c8..a8c7a3c907134ea037003d5b99f849d0ac9878a0 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=brcm63xx
 BOARDNAME:=Broadcom BCM963xx
 FEATURES:=squashfs jffs2 broken usb atm
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Build firmware images for Broadcom based xDSL/routers
        (e.g. Inventel Livebox, Siemens SE515)
index 2259496fe838f4dc48d6bfee0948703f9c7d78f4..529a7e048a45b878864cf0d394d736be78e84d26 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=iop32x
 BOARDNAME:=Intel XScale IOP32x
 FEATURES:=squashfs jffs2
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
 endef
 
index d896334e4734375c13ead0a17b07a3b15964b9e3..79e8c103f659f38e80fe7193953fe51c0c8fc924 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=ixp4xx
 BOARDNAME:=Intel XScale IXP4xx
 FEATURES:=squashfs
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
 endef
 
index 9fe548a903bb185a14b5cde4f611dc53f5f2f425..f80460fdd4f957330568961806bd54990c1655c4 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=magicbox
 BOARDNAME:=Magicbox
 FEATURES:=squashfs jffs2
 
+LINUX_VERSION:=2.6.21.5
+
 include $(INCLUDE_DIR)/kernel-build.mk
 
 # include the profiles
index 76ca28e37c089ca7ebe2e513b76b6565a58619a3..3e0e6cd3b33d945db9c1b8cea3f7edd3e8741a07 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=pxa
 BOARDNAME:=PXA
 FEATURES:=jffs2 broken
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
        Stub for boards based on intel PXA
 endef
index 27569a35db228dbe53a70d32340d3c3cb6e1b078..7d48438990695c554a0d33d241eb1e699829d937 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=rb532
 BOARDNAME:=Mikrotik RouterBoard 532
 FEATURES:=jffs2
 
+LINUX_VERSION:=2.6.21.5
+
 include $(INCLUDE_DIR)/kernel-build.mk
 
 # include the profiles
index bf0d0d41add74ef3c4d704ee3b01ee19fc917a7a..d52974ffae905bc6aa464c3352a2dc77214c268a 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=rdc
 BOARDNAME:=RDC x86
 FEATURES:=squashfs jffs2 pci broken
 
+LINUX_VERSION:=2.6.21.5
+
 define Target/Description
         Build firmware images for RDC3211 based routers
         (e.g. Airlink101 AR525W, Linksys WRT54R)
index 28b3302750754554ba32f4eddeb5fffab07c40a4..35cdb37f2ec188409014d96ab0c3d8fd45a0c3c4 100644 (file)
@@ -11,6 +11,8 @@ BOARD:=sibyte
 BOARDNAME:=SiByte MIPS
 FEATURES:=broken
 
+LINUX_VERSION:=2.6.21.5
+
 include $(INCLUDE_DIR)/kernel-build.mk
 
 # include the profiles
index 089ef585819ba84285026f807e7e7a0a10b85aa8..65e1b52f70f7b4a755ee20c8ae4b820d4a1049c8 100644 (file)
@@ -23,6 +23,8 @@ BOARDNAME:=User Mode Linux
 FEATURES:=broken
 LINUX_CONFIG:=$(CURDIR)/config/$(ARCH)
 
+LINUX_VERSION:=2.6.21.5
+
 include $(INCLUDE_DIR)/kernel-build.mk
 
 # include the profiles
index db629fab5fc4d239a6f431591bc1a0de3829e185..a870bbe2bd1c3b73669a489d8ea21c458711c2f6 100644 (file)
@@ -11,8 +11,7 @@ BOARD:=x86
 BOARDNAME:=x86
 FEATURES:=squashfs jffs2 ext2
 
-LINUX_VERSION:=2.6.22-rc5
-LINUX_KERNEL_MD5SUM:=50dda556ae492f68ff7c273e1f357c55
+LINUX_VERSION:=2.6.22-rc6
 
 include $(INCLUDE_DIR)/kernel-build.mk
 DEFAULT_PACKAGES += kmod-natsemi kmod-ne2k-pci