toolchain: only take last found libgcc* file
authorJo-Philipp Wich <jow@openwrt.org>
Fri, 27 Jun 2014 10:40:21 +0000 (10:40 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Fri, 27 Jun 2014 10:40:21 +0000 (10:40 +0000)
The current $(wildcard ...) match might return multiple files which will break subsequent cp commands
with an error like:

  cp: target `/home/user/openwrt/staging_dir/target-mips_34kc_uClibc-0.9.33.2/root-ar71xx/tmp-libc/lib/libgcc_s_pic.a' is not a directory

Prevent this issue by only taking the last path returned by globbing.

Signed-off-by: Jo-Philipp Wich <jow@openwrt.org>
SVN-Revision: 41357

package/libs/toolchain/Makefile

index 117447f5814c176854e1f9d9dd42d0fe75b7bf38..e4a78ed5f2d48a19061a9f04eba7010fa27da494 100644 (file)
@@ -289,9 +289,9 @@ define Build/Prepare
        mkdir -p $(PKG_BUILD_DIR)
 endef
 
-LIBGCC_A=$(wildcard $(TOOLCHAIN_DIR)/lib/gcc/*/*/libgcc_pic.a)
-LIBGCC_MAP=$(wildcard $(TOOLCHAIN_DIR)/lib/gcc/*/*/libgcc.map)
-LIBGCC_SO=$(wildcard $(TOOLCHAIN_DIR)/lib/libgcc_s.so.*)
+LIBGCC_A=$(lastword $(wildcard $(TOOLCHAIN_DIR)/lib/gcc/*/*/libgcc_pic.a))
+LIBGCC_MAP=$(lastword $(wildcard $(TOOLCHAIN_DIR)/lib/gcc/*/*/libgcc.map))
+LIBGCC_SO=$(lastword $(wildcard $(TOOLCHAIN_DIR)/lib/libgcc_s.so.*))
 ifeq ($(CONFIG_EXTERNAL_TOOLCHAIN),)
   ifneq ($(if $(CONFIG_USE_UCLIBC),$(CONFIG_GCC_VERSION_LINARO)),)
     BUILD_LIBGCC:=$(if $(CONFIG_avr32)$(CONFIG_m68k)$(CONFIG_powerpc),,$(PKG_BUILD_DIR)/libgcc_s.so.*)