add Default and Gumstix PXA profiles
authorFlorian Fainelli <florian@openwrt.org>
Wed, 3 Oct 2012 16:15:05 +0000 (16:15 +0000)
committerFlorian Fainelli <florian@openwrt.org>
Wed, 3 Oct 2012 16:15:05 +0000 (16:15 +0000)
Gumstix builds a fake flash image for usage in qemu

SVN-Revision: 33609

target/linux/pxa/image/Makefile
target/linux/pxa/profiles/100-Default.mk [new file with mode: 0644]
target/linux/pxa/profiles/200-Gumstix.mk [new file with mode: 0644]

index 74edb62be0d80817d7bfd274f7e43d2e364aeda7..7f2b5d4123197b723d545983440ffea94eda6a94 100644 (file)
@@ -1,5 +1,5 @@
 #
-# Copyright (C) 2008-2010 OpenWrt.org
+# Copyright (C) 2008-2012 OpenWrt.org
 #
 # This is free software, licensed under the GNU General Public License v2.
 # See /LICENSE for more information.
@@ -15,8 +15,20 @@ define Image/BuildKernel
        cp $(KDIR)/uImage $(BIN_DIR)/$(IMG_PREFIX)-uImage
 endef
 
+# Build a fake flash image for usage in Qemu
+define Image/Build/Gumstix
+       dd if=/dev/zero bs=128k count=256 of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+       dd if=$(BIN_DIR)/openwrt-pxa-gumstix-u-boot.bin conv=notrunc bs=128k \
+               of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+       dd if=$(KDIR)/root.$(1) conv=notrunc bs=128k seek=2 \
+               of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+       dd if=$(KDIR)/uImage conv=notrunc bs=128k seek=248 \
+               of=$(BIN_DIR)/$(IMG_PREFIX)-$(1)-qemu-flash.img
+endef
+
 define Image/Build
        $(call Image/Build/$(1),$(1))
+       $(call Image/Build/$(PROFILE),$(1))
 endef
 
 define Image/Build/jffs2-64k
diff --git a/target/linux/pxa/profiles/100-Default.mk b/target/linux/pxa/profiles/100-Default.mk
new file mode 100644 (file)
index 0000000..566a43f
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Default
+  NAME:=Default Profile
+  PACKAGES:=
+endef
+
+define Profile/Default/Description
+       Default PXA Profile
+endef
+$(eval $(call Profile,Default))
+
diff --git a/target/linux/pxa/profiles/200-Gumstix.mk b/target/linux/pxa/profiles/200-Gumstix.mk
new file mode 100644 (file)
index 0000000..f296414
--- /dev/null
@@ -0,0 +1,17 @@
+#
+# Copyright (C) 2012 OpenWrt.org
+#
+# This is free software, licensed under the GNU General Public License v2.
+# See /LICENSE for more information.
+#
+
+define Profile/Gumstix
+  NAME:=Gumstix
+  PACKAGES:=uboot-pxa-gumstix
+endef
+
+define Profile/Atheros-ath5k/Description
+       Package set compatible with the Gumstix boards
+endef
+$(eval $(call Profile,Gumstix))
+