tools/fakeroot: explicitly pass CPP variable
authorFelix Fietkau <nbd@nbd.name>
Wed, 13 Oct 2021 14:36:16 +0000 (16:36 +0200)
committerFelix Fietkau <nbd@nbd.name>
Wed, 13 Oct 2021 14:48:53 +0000 (16:48 +0200)
For some reason, the generated configure script fails to properly set up
the internal preprocessor command variable, causing the host OS check for
Darwin to fail after the last update.
Explicitly setting CPP fixes this issue

Signed-off-by: Felix Fietkau <nbd@nbd.name>
tools/fakeroot/Makefile

index 5c5f25e2264bed4a16e1a004787952d1042e6c82..f4333fbfb36cd1514322ffd2ebb790efe6e1be31 100644 (file)
@@ -19,7 +19,8 @@ include $(INCLUDE_DIR)/host-build.mk
 
 HOST_CONFIGURE_VARS += \
        ac_cv_header_sys_capability_h=no \
-       ac_cv_func_capset=no
+       ac_cv_func_capset=no \
+       CPP="$(HOSTCC) -E"
 
 HOST_CONFIGURE_ARGS += \
        --with-ipc=tcp