build: disable initramfs build within image builder
authorFelix Fietkau <nbd@openwrt.org>
Mon, 11 May 2015 09:17:39 +0000 (09:17 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 11 May 2015 09:17:39 +0000 (09:17 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 45673

include/image.mk

index 1b7fd2404aa2a8c6a904a14714585d2c3ae15423..b8be838313c9f0a09430c3fcf739f25b5118def3 100644 (file)
@@ -362,6 +362,7 @@ define Device/Check
   _COMPILE_TARGET = $$(if $(CONFIG_IB)$$(filter $(PROFILE),$$(PROFILES)),compile,compile-disabled)
 endef
 
+ifndef IB
 define Device/Build/initramfs
   $$(_TARGET): $(BIN_DIR)/$$(KERNEL_INITRAMFS_IMAGE)
 
@@ -373,6 +374,7 @@ define Device/Build/initramfs
        @rm -f $$@
        $$(call concat_cmd,$$(KERNEL_INITRAMFS))
 endef
+endif
 
 define Device/Build/check_size
        @[ $$(($(subst k,* 1024,$(subst m, * 1024k,$(1))))) -gt "$$(stat -c%s $@)" ] || { \