kernel: mark kmod-usb-serial-wwan as hidden
authorYousong Zhou <yszhou4tech@gmail.com>
Wed, 30 Oct 2019 12:41:34 +0000 (12:41 +0000)
committerYousong Zhou <yszhou4tech@gmail.com>
Wed, 30 Oct 2019 12:43:17 +0000 (12:43 +0000)
The kconfig symbol is an invisible one since its introduction.  It is
not supposed to be enabled on its own.

Resolves FS#1821

Signed-off-by: Yousong Zhou <yszhou4tech@gmail.com>
package/kernel/linux/modules/usb.mk

index 45c409f4cb05a5a8a1c889be14aa9712ee3b847d..2a5f1d7d5fd7e3ddc63dc99a3c1d9d4cf786a31e 100644 (file)
@@ -936,6 +936,7 @@ define KernelPackage/usb-serial-wwan
   TITLE:=Support for GSM and CDMA modems
   KCONFIG:=CONFIG_USB_SERIAL_WWAN
   FILES:=$(LINUX_DIR)/drivers/usb/serial/usb_wwan.ko
+  HIDDEN:=1
   AUTOLOAD:=$(call AutoProbe,usb_wwan)
   $(call AddDepends/usb-serial)
 endef
@@ -949,11 +950,10 @@ $(eval $(call KernelPackage,usb-serial-wwan))
 
 define KernelPackage/usb-serial-option
   TITLE:=Support for Option HSDPA modems
-  DEPENDS:=+kmod-usb-serial-wwan
   KCONFIG:=CONFIG_USB_SERIAL_OPTION
   FILES:=$(LINUX_DIR)/drivers/usb/serial/option.ko
   AUTOLOAD:=$(call AutoProbe,option)
-  $(call AddDepends/usb-serial)
+  $(call AddDepends/usb-serial,+kmod-usb-serial-wwan)
 endef
 
 define KernelPackage/usb-serial-option/description