kernel/modules: add kmod-crypto-gf128
authorFelix Fietkau <nbd@openwrt.org>
Mon, 5 Jan 2015 13:01:56 +0000 (13:01 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 5 Jan 2015 13:01:56 +0000 (13:01 +0000)
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
SVN-Revision: 43835

package/kernel/linux/modules/crypto.mk

index 1fd10d9534ef144ab6303772403be69450d43272..5d4916095925bd705c6eddce2bdf430ecf417754 100644 (file)
@@ -400,6 +400,17 @@ endef
 $(eval $(call KernelPackage,crypto-hmac))
 
 
+define KernelPackage/crypto-gf128
+  TITLE:=GF(2^128) multiplication functions CryptoAPI module
+  KCONFIG:=CONFIG_CRYPTO_GF128MUL
+  FILES:=$(LINUX_DIR)/crypto/gf128mul.ko
+  AUTOLOAD:=$(call AutoLoad,09,gf128mul)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-gf128))
+
+
 define KernelPackage/crypto-md4
   TITLE:=MD4 digest CryptoAPI module
   DEPENDS:=+kmod-crypto-hash