mpc85xx: workaround 4.14 cross compile issue
authorRyan Mounce <ryan@mounce.com.au>
Fri, 12 Oct 2018 07:46:28 +0000 (18:16 +1030)
committerHauke Mehrtens <hauke@hauke-m.de>
Sat, 20 Oct 2018 14:24:29 +0000 (16:24 +0200)
Regression introduced with 4.10 by 43c9127d94d62a232ed33ed2eab8a08657ce5472

Build will fail if system 'ar' does not support deterministic builds.
e.g. macOS with Xcode toolchain

Appears to be fixed upstream in 4.18 by af3901cbbd3de182aafb8ee553c825c0074df6a2

Signed-off-by: Ryan Mounce <ryan@mounce.com.au>
target/linux/mpc85xx/patches-4.14/103-powerpc-fix-build-cross32ar.patch [new file with mode: 0644]

diff --git a/target/linux/mpc85xx/patches-4.14/103-powerpc-fix-build-cross32ar.patch b/target/linux/mpc85xx/patches-4.14/103-powerpc-fix-build-cross32ar.patch
new file mode 100644 (file)
index 0000000..7ed52f6
--- /dev/null
@@ -0,0 +1,10 @@
+--- a/arch/powerpc/Makefile
++++ b/arch/powerpc/Makefile
+@@ -23,6 +23,7 @@ CROSS32AR            := $(CROSS32_COMPILE)ar
+ ifeq ($(HAS_BIARCH),y)
+ ifeq ($(CROSS32_COMPILE),)
+ CROSS32CC     := $(CC) -m32
++CROSS32AR     := $(AR)
+ KBUILD_ARFLAGS        += --target=elf32-powerpc
+ endif
+ endif