prereq-build: rename the openssl check to libssl, add back the old check - it is...
authorFelix Fietkau <nbd@openwrt.org>
Mon, 20 Oct 2014 09:23:55 +0000 (09:23 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 20 Oct 2014 09:23:55 +0000 (09:23 +0000)
Signed-off-by: Felix Fietkau <nbd@openwrt.org>
SVN-Revision: 42999

include/prereq-build.mk

index 4a87c9211aff402f58ba34bc62661130030835a9..5a743225f65978063d023b5ff3f2d969f476efd3 100644 (file)
@@ -168,13 +168,17 @@ $(eval $(call RequireCommand,svn, \
        Please install the subversion client. \
 ))
 
-define Require/openssl
+define Require/libssl
        echo 'int main(int argc, char **argv) { SSL_library_init(); return 0; }' | \
                gcc -include openssl/ssl.h -x c -o $(TMP_DIR)/a.out - -lcrypto -lssl
 endef
 
-$(eval $(call Require,openssl, \
-       Please install openssl (with development headers) \
+$(eval $(call Require,libssl, \
+       Please install the openssl library (with development headers) \
+))
+
+$(eval $(call RequireCommand,openssl, \
+       Please install openssl. \
 ))
 
 define Require/gnu-find