kirkwood: Add RTC driver to kernel for working hctosys
authorPaul Wassi <p.wassi@gmx.at>
Sun, 23 Oct 2016 12:21:22 +0000 (14:21 +0200)
committerJohn Crispin <john@phrozen.org>
Wed, 26 Oct 2016 07:41:28 +0000 (09:41 +0200)
Build the RTC driver into the kernel, (and remove the optional module), in order
to make hctosys working. (Currently the module is loaded after hctosys has failed previously)

Signed-off-by: Paul Wassi <p.wassi@gmx.at>
target/linux/kirkwood/config-4.4
target/linux/kirkwood/profiles/100-generic.mk
target/linux/kirkwood/profiles/110-nas.mk

index 1caec8b98944511c20d4e5e0882322e4dac0247e..8ca0ebb04e161e651e38bc0522c1932a0f201db6 100644 (file)
@@ -266,7 +266,7 @@ CONFIG_REGMAP=y
 CONFIG_REGULATOR=y
 CONFIG_REGULATOR_FIXED_VOLTAGE=y
 CONFIG_RTC_CLASS=y
-# CONFIG_RTC_DRV_MV is not set
+CONFIG_RTC_DRV_MV=y
 CONFIG_RWSEM_XCHGADD_ALGORITHM=y
 CONFIG_SCHED_HRTICK=y
 # CONFIG_SCHED_INFO is not set
index f07cea80d6837e3025e7cdcab13edc4fdb39351d..07371737b579aa5d73623a89518f30c73f59847b 100644 (file)
@@ -11,7 +11,7 @@ define Profile/Generic
        kmod-mmc kmod-mvsdio kmod-usb2 kmod-usb-storage \
        kmod-i2c-core kmod-i2c-mv64xxx \
        kmod-ata-core kmod-ata-marvell-sata \
-       kmod-rtc-marvell kmod-thermal-kirkwood \
+       kmod-thermal-kirkwood \
        kmod-mwl8k swconfig wpad-mini
 endef
 
index 614dc4d7543b2b6de377c6585936202a4c26b0d8..7ccef69aa86dfbce8af6d41b5525030f3f819828 100644 (file)
@@ -8,7 +8,7 @@
 define Profile/DOCKSTAR
   NAME:=Seagate FreeAgent Dockstar
   PACKAGES:= \
-       kmod-rtc-marvell kmod-usb2 kmod-usb-storage
+       kmod-usb2 kmod-usb-storage
 endef
 
 define Profile/DOCKSTAR/Description
@@ -21,7 +21,7 @@ define Profile/GOFLEXHOME
   NAME:=Seagate GoFlexHome
   PACKAGES:= \
        kmod-ata-core kmod-ata-marvell-sata \
-       kmod-rtc-marvell kmod-usb2 kmod-usb-storage \
+       kmod-usb2 kmod-usb-storage \
        uboot-envtools
 endef
 
@@ -48,7 +48,7 @@ define Profile/IB62X0
   NAME:=RaidSonic ICY BOX IB-NAS62x0
   PACKAGES:= \
        kmod-ata-core kmod-ata-marvell-sata \
-       kmod-rtc-marvell kmod-usb2 kmod-usb-storage
+       kmod-usb2 kmod-usb-storage
 endef
 
 define Profile/IB62X0/Description
@@ -86,7 +86,7 @@ define Profile/NSA310S
   NAME:=ZyXEL NSA310S
   PACKAGES:= \
        kmod-ata-core kmod-ata-marvell-sata \
-       kmod-rtc-marvell kmod-usb2 kmod-usb-storage
+       kmod-usb2 kmod-usb-storage
 endef
 
 define Profile/NSA310S/Description