comgt: fix 3g redialling if dongle is physically reattached (#11567, #12008)
authorJo-Philipp Wich <jow@openwrt.org>
Sun, 9 Sep 2012 19:46:38 +0000 (19:46 +0000)
committerJo-Philipp Wich <jow@openwrt.org>
Sun, 9 Sep 2012 19:46:38 +0000 (19:46 +0000)
SVN-Revision: 33350

package/comgt/Makefile
package/comgt/files/3g.usb

index ef0164ea35249c3db6428337c1e003c1bd0122c6..ae8aa668baa2155e5ee7ce3f17a81e828ed45b90 100644 (file)
@@ -9,7 +9,7 @@ include $(TOPDIR)/rules.mk
 
 PKG_NAME:=comgt
 PKG_VERSION:=0.32
-PKG_RELEASE:=19
+PKG_RELEASE:=20
 
 PKG_SOURCE:=$(PKG_NAME).$(PKG_VERSION).tgz
 PKG_SOURCE_URL:=@SF/comgt
index 1dabc0c98fc5fd0e5a813635f15af99f9956e886..fd6837e650345de94c41a189a234fbc036d98c78 100644 (file)
@@ -10,8 +10,8 @@ find_3g_iface() {
        config_get proto "$cfg" proto
        [ "$proto" = 3g ] || return 0
 
-       local dev
-       config_get dev "$cfg" device
+       # bypass state vars here because 00-netstate could clobber .device
+       local dev=$(uci_get network "$cfg" device)
 
        if [ "${dev##*/}" = "${tty##*/}" ]; then
                if [ "$ACTION" = add ]; then