kernel/modules: add kmod-crypto-gcm
authorFelix Fietkau <nbd@openwrt.org>
Mon, 5 Jan 2015 13:02:14 +0000 (13:02 +0000)
committerFelix Fietkau <nbd@openwrt.org>
Mon, 5 Jan 2015 13:02:14 +0000 (13:02 +0000)
Signed-off-by: Stijn Tintel <stijn@linux-ipv6.be>
SVN-Revision: 43838

package/kernel/linux/modules/crypto.mk

index 9d69cce9d5fe9b385b48ce27138102aeea7ac66f..73f36beaa124a3ec9a4d01748f7b60ccad5a5fe2 100644 (file)
@@ -400,6 +400,18 @@ endef
 $(eval $(call KernelPackage,crypto-hmac))
 
 
+define KernelPackage/crypto-gcm
+  TITLE:=GCM/GMAC CryptoAPI module
+  DEPENDS:=+kmod-crypto-ctr +kmod-crypto-ghash +kmod-crypto-null
+  KCONFIG:=CONFIG_CRYPTO_GCM
+  FILES:=$(LINUX_DIR)/crypto/gcm.ko
+  AUTOLOAD:=$(call AutoLoad,09,gcm)
+  $(call AddDepends/crypto)
+endef
+
+$(eval $(call KernelPackage,crypto-gcm))
+
+
 define KernelPackage/crypto-gf128
   TITLE:=GF(2^128) multiplication functions CryptoAPI module
   KCONFIG:=CONFIG_CRYPTO_GF128MUL