kernel: bump 3.18 to 3.18.132
authorKoen Vandeputte <koen.vandeputte@ncentric.com>
Tue, 15 Jan 2019 08:19:44 +0000 (09:19 +0100)
committerKoen Vandeputte <koen.vandeputte@ncentric.com>
Wed, 16 Jan 2019 11:56:30 +0000 (12:56 +0100)
Refreshed all patches.

Compile-tested: adm5120
Runtime-tested: none

Signed-off-by: Koen Vandeputte <koen.vandeputte@ncentric.com>
include/kernel-version.mk
target/linux/generic/pending-3.18/630-packet_socket_type.patch
target/linux/generic/pending-3.18/902-debloat_proc.patch

index 63f9da8428cad09a51be70be348e6403ebf80fbd..61bea1cf741716ea25fce789665431f88bb57f37 100644 (file)
@@ -2,12 +2,12 @@
 
 LINUX_RELEASE?=1
 
-LINUX_VERSION-3.18 = .131
+LINUX_VERSION-3.18 = .132
 LINUX_VERSION-4.9 = .148
 LINUX_VERSION-4.14 = .93
 LINUX_VERSION-4.19 = .9
 
-LINUX_KERNEL_HASH-3.18.131 = 04600ce96e4c7642b9eaa4814f4930c79b53010b1c155d23e5ac0aeba6f455e2
+LINUX_KERNEL_HASH-3.18.132 = c187bd0322372bd34c862cbb06a1996a63524ccb401466362b57ede45901a879
 LINUX_KERNEL_HASH-4.9.148 = 6067151b0225a8de1ab79abc9be7bae237eaca0cd838eb26684169560d88a994
 LINUX_KERNEL_HASH-4.14.93 = bb125fb204f7089782e179126121dd0f0aad9f02b7517ce3744982254c221bad
 LINUX_KERNEL_HASH-4.19.9 = fc116cc6829c73944215d3b3ac0fc368dde9e8235b456744afffde001269dbf2
index 81e296e0315cfc47a17a4a8c526fccefe4ee3e3d..21f37321674b312e9c28603c8e260ade057e7cd3 100644 (file)
@@ -83,7 +83,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        if (!net_eq(dev_net(dev), sock_net(sk)))
                goto drop;
  
-@@ -2862,6 +2864,7 @@ static int packet_create(struct net *net
+@@ -2866,6 +2868,7 @@ static int packet_create(struct net *net
        spin_lock_init(&po->bind_lock);
        mutex_init(&po->pg_vec_lock);
        po->prot_hook.func = packet_rcv;
@@ -91,7 +91,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
  
        if (sock->type == SOCK_PACKET)
                po->prot_hook.func = packet_rcv_spkt;
-@@ -3485,6 +3488,16 @@ packet_setsockopt(struct socket *sock, i
+@@ -3489,6 +3492,16 @@ packet_setsockopt(struct socket *sock, i
                po->xmit = val ? packet_direct_xmit : dev_queue_xmit;
                return 0;
        }
@@ -108,7 +108,7 @@ Signed-off-by: Felix Fietkau <nbd@nbd.name>
        default:
                return -ENOPROTOOPT;
        }
-@@ -3536,6 +3549,13 @@ static int packet_getsockopt(struct sock
+@@ -3540,6 +3553,13 @@ static int packet_getsockopt(struct sock
        case PACKET_VNET_HDR:
                val = po->has_vnet_hdr;
                break;
index c629d1020d2ba516214be157f77409003f9f3157..95efe78ebce5eae6bd92aa7260b9d43e3df7eb5d 100644 (file)
                goto err;
 --- a/net/core/sock.c
 +++ b/net/core/sock.c
-@@ -2941,6 +2941,8 @@ static __net_initdata struct pernet_oper
+@@ -2944,6 +2944,8 @@ static __net_initdata struct pernet_oper
  
  static int __init proto_init(void)
  {