kernel: add japanese codepages
authorJohn Crispin <john@openwrt.org>
Tue, 1 Jul 2014 10:26:03 +0000 (10:26 +0000)
committerJohn Crispin <john@openwrt.org>
Tue, 1 Jul 2014 10:26:03 +0000 (10:26 +0000)
Signed-off-by: John Crispin <blogic@openwrt.org>
SVN-Revision: 41437

package/kernel/linux/modules/nls.mk

index 224fd0378acf993055c4b6f409b961db9c8e14ff..55c5c1a8a83bc6d5e0eab8931ee2cc7fa00bf74f 100644 (file)
@@ -131,6 +131,22 @@ endef
 $(eval $(call KernelPackage,nls-cp866))
 
 
+define KernelPackage/nls-cp932
+  SUBMENU:=Native Language Support
+  TITLE:=Codepage 932 (Japanese)
+  KCONFIG:=CONFIG_NLS_CODEPAGE_932
+  FILES:=$(LINUX_DIR)/fs/nls/nls_cp932.ko
+  AUTOLOAD:=$(call AutoLoad,25,nls_cp932)
+  $(call AddDepends/nls)
+endef
+
+define KernelPackage/nls-cp932/description
+  Kernel module for NLS Codepage 932 (Japanese)
+endef
+
+$(eval $(call KernelPackage,nls-cp932))
+
+
 define KernelPackage/nls-cp1250
   SUBMENU:=Native Language Support
   TITLE:=Codepage 1250 (Eastern Europe)