tools/quilt: update to 0.67
authorRosen Penev <rosenp@gmail.com>
Fri, 25 Feb 2022 04:19:32 +0000 (20:19 -0800)
committerPaul Spooren <mail@aparcar.org>
Fri, 25 Feb 2022 13:12:39 +0000 (14:12 +0100)
  - Call pager with original LANG environment variable
  - Consistently complain early if no series file is found
  - Fix handling of symbolic links by several commands
  - Tighten the patch format parsing
  - Reuse the shell (performance)
  - Document the series file format further
  - Document that quilt loads /etc/quilt.quiltrc
  - configure: Make stat configurable
  - series: Minor optimizations
  - setup: Don't obey the settings of any englobing .pc
  - setup: Default to fast mode
  - quilt.el: Fix documentation of quilt-pc-directory
  - quilt.el: Load /etc/quilt.quiltrc if ~/.quiltrc doesn't exist
  - quilt.el: Fix quilt-editable when QUILT_PATCHES_PREFIX is set

Refresh patches.

Signed-off-by: Rosen Penev <rosenp@gmail.com>
[add changelog]
Signed-off-by: Paul Spooren <mail@aparcar.org>
tools/quilt/Makefile
tools/quilt/patches/000-relocatable.patch
tools/quilt/patches/001-fix_compile.patch

index 149b7996a36951402a3f3442b2eeffcb2f04bfdf..c16f989b5d198f7bab6d9f053fb7390df5a4d82c 100644 (file)
@@ -7,11 +7,11 @@
 include $(TOPDIR)/rules.mk
 
 PKG_NAME:=quilt
-PKG_VERSION:=0.66
+PKG_VERSION:=0.67
 
 PKG_SOURCE:=$(PKG_NAME)-$(PKG_VERSION).tar.gz
 PKG_SOURCE_URL:=@SAVANNAH/quilt
-PKG_HASH:=314b319a6feb13bf9d0f9ffa7ce6683b06919e734a41275087ea457cc9dc6e07
+PKG_HASH:=3be3be0987e72a6c364678bb827e3e1fcc10322b56bc5f02b576698f55013cc2
 
 include $(INCLUDE_DIR)/host-build.mk
 
index 666c4b47913ee0c04fd57cdb7a9ca67bef60d019..caf5eb89a6e2b7bf4d58255002b062898f45cef9 100644 (file)
@@ -92,7 +92,7 @@
  SHELL:=               @BASH@ # It does not work if dash is used as a shell, for example
  GREP :=               @GREP@
  TAIL :=               @TAIL@
-@@ -32,7 +32,7 @@ AWK :=               @AWK@
+@@ -33,7 +33,7 @@ AWK :=               @AWK@
  FIND :=               @FIND@
  XARGS :=      @XARGS@
  DIFF :=               @DIFF@
  MKTEMP :=     @MKTEMP@
  MSGMERGE :=   @MSGMERGE@
  MSGFMT :=     @MSGFMT@
-@@ -49,8 +49,8 @@ USE_NLS :=   @USE_NLS@
+@@ -50,8 +50,8 @@ USE_NLS :=   @USE_NLS@
  STAT_HARDLINK := @STAT_HARDLINK@
  PATCH_WRAPPER := @PATCH_WRAPPER@
  
index 56e38728de3cefbfafaf62729cc491d84efaa5e2..ef6f8ff608388a3a462b5d01be401b1a090ea57a 100644 (file)
@@ -1,6 +1,6 @@
 --- a/Makefile.in
 +++ b/Makefile.in
-@@ -275,13 +275,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
+@@ -276,13 +276,10 @@ $(patsubst %.in,%,$(wildcard bin/*.in qu
        @$(if $(filter $@,$(NON_EXEC_IN)),,chmod +x $@)
  
  configure : configure.ac aclocal.m4