fix .dep_files exclusion in rdep calls
authorNicolas Thill <nico@openwrt.org>
Sat, 1 Sep 2007 05:20:21 +0000 (05:20 +0000)
committerNicolas Thill <nico@openwrt.org>
Sat, 1 Sep 2007 05:20:21 +0000 (05:20 +0000)
SVN-Revision: 8567

include/package.mk

index 0b333529410106fbad6f2632f6a6c490fdef4d02..254588e8a0402824e2ba8dd376f47596f6939af0 100644 (file)
@@ -32,8 +32,8 @@ ifeq ($(DUMP)$(filter prereq clean refresh update,$(MAKECMDGOALS)),)
   ifneq ($(if $(QUILT),,$(CONFIG_AUTOREBUILD)),)
     define Build/Autoclean
       $(PKG_BUILD_DIR)/.dep_files: $(STAMP_PREPARED)
-      $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED),$(PKG_BUILD_DIR)/.dep_files,-x "/.dep_*")
-      $(if $(filter prepare,$(MAKECMDGOALS)),,$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),,-x "/.dep_*" -x "*/ipkg*"))
+      $(call rdep,${CURDIR} $(PKG_FILE_DEPEND),$(STAMP_PREPARED),$(PKG_BUILD_DIR)/.dep_files,-x "*/.dep_*")
+      $(if $(filter prepare,$(MAKECMDGOALS)),,$(call rdep,$(PKG_BUILD_DIR),$(STAMP_BUILT),,-x "*/.dep_*" -x "*/ipkg*"))
     endef
   endif
 endif